PAT A1102 Invert a Binary Tree (25分)

1102 Invert a Binary Tree 25分

原题

The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

大体题意

将给定的二叉树左右颠倒,并输出其层序遍历和中序遍历

思路

两种方法:1.建树的时候就将左右子针互调
2.遍历的时候调换左右子树的遍历顺序

代码

#include<iostream>
using namespace std;
#include <algorithm>
#include <string>
#include <queue>
typedef struct BiNode
{
	int data;
	int lchild, rchild;
}BiNode, * pnode;

int has_p[11];
BiNode tree[11];
int n;

int first = 0;

void LevelTrave(int root)
{
	queue<int> q;
	q.push(root);
	while (!q.empty())
	{
		int len = q.size();
		for (int i = 0; i < len; i++)
		{
			int r = q.front();
			q.pop();
			if (first)
				cout << " ";
			cout << r;
			first = 1;
			if (tree[r].lchild != -1)
				q.push(tree[r].lchild);
			if (tree[r].rchild != -1)
				q.push(tree[r].rchild);
		}
	}
}

int second = 0;

void inorderTrave(int root)
{
	if (tree[root].lchild != -1)
		inorderTrave(tree[root].lchild);
	if (second)
		cout << " ";
	cout << root;
	second = 1;
	if (tree[root].rchild != -1)
		inorderTrave(tree[root].rchild);
}

int main()
{
	cin >> n;
	string a, b;
	for (int i = 0; i < n; i++)
	{
		tree[i].data = i;
		cin >> a >> b;
		if (a != "-")
		{
			int p = stoi(a);
			tree[i].rchild = p;
			has_p[p] = 1;
		}
		else
		{
			tree[i].rchild = -1;
		}
		if (b != "-")
		{
			int p = stoi(b);
			tree[i].lchild = p;
			has_p[p] = 1;
		}
		else
			tree[i].lchild = -1;
	}
	int root = 0;
	for(int i=0;i<n;i++)
		if (has_p[i] == 0)
		{
			root = i;
			break;
		}
	LevelTrave(root);
	cout << endl;
	inorderTrave(root);
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值