PAT A1013 Battle Over Cities (25分)

PAT A1013 Battle Over Cities 25分

原题

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city​1​​ -city​2​​ and city​1​​ -city​3​​ . Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​ -city​3​​ .
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

大体题意

在战争中有些城市会被攻占,两个城市仅靠一个城市连接,如果中间的城市被攻占了以后,就要求在两个城市间修筑一条路,让两个城市可以连接
题目要求求出需要的最少的公路数量

思路

本质就是,当去掉一个顶点以及它连接的边之后,计算图的连通分量数,其需要修建的公路数即为连通分量数减1。
计算图的连通分量数由深度遍历或者广度遍历实现。
如何实现“去掉一个顶点以及它连接的边”呢?
在遍历前将需要去掉的结点v标记成已访问即可。

代码

#include <iostream>
using namespace std;
#include <queue>

int edge[1001][1001];
bool visit[1010];
int n, m, k;

void BFS(int v)//BFS不做改变
{
	queue<int> Q;
	visit[v] = true;
	Q.push(v);
	while (!Q.empty())
	{
		v = Q.front();
		Q.pop();
		for (int i = 1; i <= n; i++)
		{
			if (edge[v][i] == 1 && !visit[i])
			{
				visit[i] = true;
				Q.push(i);
			}
		}
	}
}

void BFSTraverse(int node)
{
	
	int num = 0;
	visit[node] = true;//去掉被攻陷的城市
	for (int i = 1; i <= n; i++)
	{
		if (!visit[i])
		{
			BFS(i);
			num++;//记录连通分量数
		}
	}
	cout << num - 1 << endl;
}


int main()
{
	
	cin >> n >> m >> k;
	int pre, las;
	for (int i = 0; i < m; i++)
	{
		cin >> pre >> las;
		edge[pre][las] = 1;
		edge[las][pre] = 1;
	}
	int knode;
	for (int i = 0; i < k; i++)
	{
		fill(visit, visit + 1010, false);
		cin >> knode;
		BFSTraverse(knode);
	}
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值