PAT A1018 Public Bike Management (30分)

1018 Public Bike Management 30分

原题

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.
The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.
When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
在这里插入图片描述

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​ , we have 2 different shortest paths:
1.PBMC -> S​1​​ -> S​3​​ . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1 and then take 5 bikes to S​3​​ , so that both stations will be in perfect conditions.
2.PBMC -> S​2​​ -> S​3​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations;S​p​​ , the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​ , S​j​​ , and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​ . All the numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​ −>⋯−>S​p​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.
Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

大体题意

输入的第一个值Cmax是一个车站的最多自行车存量,当一个车站里面的自行车的数量刚好是满的一般,那么称为完美状态
从控制中心出发去往目的车站(Sp),一路上经过的车站,如果车站的车多于完美状态,就带走一些车,如果车站的车少于完美状态,就补上一些车。但是一路上的车站自给自足的可能性很低,因此需要从控制中心带一些车走,也需要最后带回一些车。
现在题目就是要求得到一个最短路径,如果最短路径有多条,则选择从控制中心带走最少车的那条路径,如果这样还有多条路径,则选择最后带回车最少的那条路径,题目保证没有多条。

思路

最短路径需要Dijkstra,但是只有Dijkstra是不够的。因为带走最少车辆minneed和带回最少车辆minback不满足最优子结构条件,不是简单的相加。也就是说,只有到最后整条路径确定了之后才能选择最小的need和back,在单个结点是无法知道的。
因此,则要求Dijkstra可以得到所有的最短路径,这里选择使用vector数组保存顶点的所有前驱顶点,如题所示的图,其最短路径的数组就为:

pre[0]:
pre[1]:0
pre[2]:0
pre[3]:1、2

然后使用DFS,计算每条最短路径所需的need和back,最后按照要求选择理想的路径。其主要思想是通过递归得到完整的temppath,计算该路径的need和back,根据情况保存结果到path。这里temppath和path都使用vector,比数组更方便赋值。但是在判断完一个结点后需将其弹出,具体在代码中显现。
最后,path的路径是从后往前保存的,所以输出时,需要从后往前输出

代码

#include <iostream>
using namespace std;
const int inf = 999999999;
#include <vector>
#include <algorithm>

int cm, n, sp, m;
int minneed = inf, minback = inf;
int e[510][510], dis[510], weight[510], s[510];
vector<int>pre[510], path, temppath;

void print_pre()//输出所有最短路径
{
	for (int i = 0; i <= n; i++)
	{
		cout << "pre " << i << ":  ";
		for (int j = 0; j < pre[i].size(); j++)
			cout << pre[i][j] << " ";
		cout << endl;
	}
}

void Dijstra()
{
	for(int i = 0; i <= n; i++)//初始化
	{
		s[i] = 0;
		dis[i] = e[0][i];
		if (e[0][i] < inf)
			pre[i].push_back(0);
	}
	s[0] = 1;
	for (int i = 1; i <= n; i++)
	{
		int min = inf;
		int k = -1;
		for (int j = 0; j <= n; j++)
		{
			if (s[j] == 0 && dis[j] < min)
			{
				min = dis[j];
				k = j;
			}
		}
		s[k] = 1;
		for (int j = 0; j <= n; j++)
		{
			if (s[j] == 0 && dis[j] > dis[k] + e[k][j])
			{
				dis[j] = dis[k] + e[k][j];
				pre[j].clear();
				pre[j].push_back(k);
			}
			else if (s[j] == 0 && dis[j] == dis[k] + e[k][j])
				pre[j].push_back(k);
		}
	}
	//print_pre();
}

void dfs(int v)
{
	temppath.push_back(v);
	if (v == 0)
	{
		int need = 0, back = 0;
		for (int i = temppath.size() - 1; i >= 0; i--)
		{
			int k = temppath[i];
			if (weight[k] > 0)//该车站的车大于满的一半 / 需要把车带走
				back += weight[k];
			else
			{
				if (back > abs(weight[k]))//有足够的自行车填满
				{
					back += weight[k];//此时的weight[k]是负的
				}
				else//不够填满,则需要从need里加
				{
					need += (abs(weight[k]) - back);
					back = 0;//此时没有车可以带回去
				}
			}
		}
		if (need < minneed)//如果最短路径有多个,求能带的最少的自行车的数目的那条
		{
			minneed = need;
			minback = back;
			path = temppath;
		}
		else if (need == minneed && back < minback)//如果还有不同的路,那么就找一个从车站带回的自行车数目最少的那条
		{
			minback = back;
			path = temppath;
		}
		temppath.pop_back();//最后结束了,将最后一个结点从temppath中删除,继续遍历(也可以理解为因为有return所以没有经历后面的pop_back)
		return;
	}
	for (int i = 0; i < pre[v].size(); i++)
		dfs(pre[v][i]);
	temppath.pop_back();//同上,只是上面删除的是最后的结点,这个是删除中间路程的结点
}

int main()
{
	cin >> cm >> n >> sp >> m;
	fill(e[0], e[0] + 510 * 510, inf);
	for (int i = 1; i <= n; i++)
	{
		cin >> weight[i];
		weight[i] = weight[i] - cm / 2;//weight与完美状态之间的差距/正:大于满的一半,负:小于满的一半
	}
	for (int i = 0; i < m; i++)
	{
		int a, b;
		cin >> a >> b;
		cin >> e[a][b];
		e[b][a] = e[a][b];
	}
	Dijstra();
	dfs(sp);
	cout << minneed << " 0";
	for (int i = path.size() - 2; i >= 0; i--)
		cout << "->" << path[i];
	cout << " " << minback << endl;
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值