[kuangbin带你飞]专题十四 数论基础-C - Aladdin and the Flying Carpet

C - Aladdin and the Flying Carpet
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: ab(1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and bdenotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2



首先想到唯一分解定理:

然后还要知道,任意一个数的因子数量k为:



所以这题怎么做就大致明白了
先打一张素数表,然后统计n中每个质因数的指数,根据上式子来计算体重输入的a共有多少个因子
因为因子是成对出现的,所以得出的因子数除以2就能知道有多少种组合
接下来暴力算出比b小的a的因子有多少个,两者相减就行了。
下面贴代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
const long long maxn =1000047;
long long vis[maxn];
long long prime[maxn];
long long p_n=0;
void init(){
    p_n=0;
    long long i,j;
    memset(vis, 0, sizeof(vis));
    for(i=2;i<=maxn;i++){
        if(!vis[i]){
            prime[p_n++] = i;
            for(j=i*i;j<=maxn;j+=i){
                vis[j]=1;
            }
        }
    }
}
int main(){
    long long i,rnd=1,k,t,a,b;
    init();
    
    /*for(i=0;i<=p_n;i++){
     cout<<prime[i]<<endl;
     }*/
    long long save;
    
    scanf("%lld",&t);
    while(t--){
        scanf("%lld%lld",&a,&b);
        long long god=a;
        long long ans=1;
        
        for(i=0;i<p_n&&prime[i]*prime[i]<=a;i++){
            int judge=0;
            save=0;
            while(a%prime[i]==0){
                save++;
                a=a/prime[i];
                judge=1;
            }
            if(judge){
                ans *= save+1;
            }
        }
        if(a>1){
            ans=ans*2;
        }
        
        
        long long other=0;
        long long result;
        if(god/b<b){
            result=0;
        }else{
            for(i=1;i<b;i++){
                if(god%i==0){
                    other++;
                }
            }
            result=ans/2-other;
        }
        printf("Case %lld: %lld\n",rnd,result);
        rnd++;
    }
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值