HDU3466 Proud Merchants 01背包 思考 TWT Tokyo Olympic 2Combo -2 未完待续

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5524    Accepted Submission(s): 2326


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

Author
iSea @ WHU
 

Source

某岛上的商人买价值为v价格为p的商品,神奇的是如果你购买该件商品时身上的钱少于q的话你是不能购买此商品的。。。

现在给你商品数量n和拥有的钱m,问能买到商品的最大值


一开始用基本的01背包写了,果然错了。。。。

之前看题目清单的时候瞄了一眼知道要排序。。。然而到底要在什么地方排序呢,。。想不明白。。。好困。。。搜了题解,。。。

居然对q-p排序!!

想了一会儿没明白。。。

继续想。。。

是这样的,01背包的状态转移方程中每个状态是从上一个状态中转移过来的,那么上一个状态就显得尤为重要。买到第i个商品的时候,此时会用到的上一个状态是f[

好困。。。。明天补完

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int maxn=5010;
struct unit{
    int P,Q,V;
}save[maxn];
int f[maxn];
bool compare(unit a,unit b){
    return (a.Q-a.P)<(b.Q-b.P);
}
int main(){
    int n,m,i,j;
    while(~scanf("%d%d",&n,&m)){
        //p,q,v
        for(i=1;i<=n;i++){
            scanf("%d%d%d",&save[i].P,&save[i].Q,&save[i].V);
        }
        memset(f, 0, sizeof(f));
        sort(save+1, save+1+n, compare);
        for(i=1;i<=n;i++){
            for(j=m;j>=save[i].Q;j--){
                f[j]=max(f[j],f[j-save[i].P]+save[i].V);
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值