poj2386 Lake Counting dfs入门 TWT Tokyo Olympic 2combo-2

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30099 Accepted: 15044

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source


根据题目输入,“W”代表土地, “.”代表积水,如果一个W的八个方向存在W,那么认为这两个W是相连在一起的

求这个图上有多少个水洼。。就是求有多少块相连的W

书中给出的方法很聪明。。。。。反正我觉得很聪明。。。就是从任意一个W开始做dfs,每次都把自身变成积水,然后对其八个方向的为W的点做dfs

这样一次dfs就能消除一个连通块,根据做了多少次dfs就能知道有多少个水洼

下面代码:

/*
 ━━━━━┒
 ┓┏┓┏┓┃μ'sic foever!!
 ┛┗┛┗┛┃\○/
 ┓┏┓┏┓┃ /
 ┛┗┛┗┛┃ノ)
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┃┃┃┃┃┃
 ┻┻┻┻┻┻
 */
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const long long maxn=110;
int n,m;
char save[maxn][maxn];
void dfs(int x,int y){
	//cout<<"what??"<<endl;
	save[x][y]='.';
	int i,j;
	for(i=-1;i<=1;i++){
		for(j=-1;j<=1;j++){
			if(x+i>=1&&x+i<=n&&y+j<=m&&y+j>=1&&save[x+i][y+j]=='W'){
				dfs(x+i,y+j);
			}
		}
	}
}
int main(){
    int i,j;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++){
    	for(j=1;j<=m;j++){
    		//scanf("%c",save[i][j]);
    		cin>>save[i][j];
		}
	}
	int ans=0;
	for(i=1;i<=n;i++){
		for(j=1;j<=m;j++){
			if(save[i][j]=='W'){
				ans++;
				dfs(i,j);
			}
		}
	}
	printf("%d\n",ans);
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值