HDU5532 Almost Sorted Array 最长上升子序列 国庆咸鱼 未完待续

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3305    Accepted Submission(s): 828


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source

大家好像都是用最长上升子序列来做的,然而我并不知道那个状态转移方程怎么写,(其实根本就没有想到最长上升子序列)

首先对题目给的串统计合法的不下降个数和合法的不上升个数(分别叫做LowToBig,BigToLow)

当BigToLow或LowToBig==n-1时,这个数列是肯定满足题意的

BigToLow或LowToBig==n-2时,我们还有去除一个数字来挽救的余地,那么究竟能不能挽救的回来

如下图,打叉的那对数字出了问题,那么看看分别移去箭头所指的两个数字是否能合法,这样来挽救。。。。


下面代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const int maxn=1e5+10;
const int INF=1e10;
int save[maxn];
int main(){
    int t,i,j;
    scanf("%d",&t);
    int LowToBig=0,BigToLow=0;
    int position1=INF,position2=INF;
    while(t--){
        int n;
        scanf("%d",&n);
        LowToBig=0,BigToLow=0;
        position1=INF,position2=INF;
        for(i=0;i<n;i++){
            scanf("%d",&save[i]);
            if(i>0){
                if(position1==INF&&save[i]<save[i-1]){
                    position1=i-1;
                }
                if(position2==INF&&save[i]>save[i-1]){
                    position2=i-1;
                }
                if(save[i]>save[i-1]){
                    LowToBig++;
                }else if(save[i]<save[i-1]){
                    BigToLow++;
                }else{
                    LowToBig++;
                    BigToLow++;
                }
            }
        }
        bool flag=false;
        if(LowToBig==n-1||BigToLow==n-1){
            flag=true;
        }
        if(LowToBig==n-2){
            if(position1==0||position1==n-2||save[position1+1]>=save[position1-1]||save[position1+2]>=save[position1]){
                flag=true;
            }
        }
        if(BigToLow==n-2){
            if(position2==0||position2==n-2||save[position2+1]<=save[position2-1]||save[position2+2]<=save[position2]){
                flag=true;
            }
        }
        if(flag){
            printf("YES\n");
        }else{
            printf("NO\n");
        }
    }
    return 0;
}

哪天有空补上最长上升子序列的做法吧

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值