poj2155 二维树状数组 二位线段树 灵活运用 待补完

回宿舍无聊的时候补完。。。
Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 25353 Accepted: 9400

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
题目是让每次对一个子矩阵进行翻转(0变1,1变0),然后有多次询问,询问某个点是0还是1
这题可以用二维的树状数组来解决,考虑传统的树状数组是改变某个点,然后查询某一段,而这个题是改变某一段,查询某个点,需要进行一下转换,将原来的改值变成查询,查询变成改值。改制时相当于对区间分别进行修改,而查询某个点时,就是将 覆盖这个点的区间全加起来,然后把一维的改成二维的就可以了。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int save[maxn+10][maxn+10];
int n;
int lowbit(int x) {
    return x & (-x);
}
int update(int x,int y/*, int val*/) {
	int result;
    for(int i = x; i <= n+1; i += lowbit(i)) {
        for(int j = y; j <= n+1; j += lowbit(j)) {
            //save[i][j] += val;
            result += save[i][j];
        }
    }
    return result;
}
int query(int x, int y,int val) {
    int sum = 0;
    for(int i = x; i > 0; i -= lowbit(i)) {
        for(int j = y; j > 0; j -= lowbit(j)) {
            //sum += save[i][j];
            save[i][j] += val;
        }
    }
    return sum;
}
/*int getSingle(int x, int y) {
    return query(x, y) + query(x-1, y-1) - query(x-1, y) - query(x, y-1);
}*/
int main(){
    int t,q,i,j,k;
    scanf("%d",&t);
    while(t--){
        char in;
        memset(save, 0, sizeof(save));
        scanf("%d%d",&n,&q);
        for(i=1;i<=q;i++){
            cin>>in;
            int x1,y1,x2,y2,n;
            if(in=='C'){
                scanf("%d%d%d%d",&x1, &y1, &x2, &y2);
                /*for(j=x1;j<=x2;j++){
                    for(k=y1;k<=y2;k++){
                        update(j, k, 1);
                    }
                }*/
                query(x1-1,y1-1,1);
                query(x1-1,y2,1);
                query(x2,y1-1,1);
                query(x2,y2,1);
                
            }else{
                scanf("%d%d",&x1,&y1);
                //int res = getSingle(x1, y1);
            	int res = update(x1,y1);
                printf("%d\n",res%2);
            }
        }
        printf("\n");
    }
    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值