poj1330 Nearest Common Ancestors LCA Tarjan 待补完

Nearest Common Ancestors
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26767 Accepted: 13807

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

Source



题意:
题中给n个点,n-1条边,最后给一个点对要求求这个点对的最近公共祖先。mirror58229告诉我的lca水题。。。。可是题目数据实在是太水了,在不明不白的情况下A了。。
因为题中要求的公共祖先是唯一的,所以我们必须要确定一个根结点,不然这个图各个方向拉一拉答案就不一样了。
和之前每周训练有不同之处,边是不用双向添加的。而至于找根结点这个问题,我们需要找一个没有祖先的点作为它的根结点。
不过这题每次只有一次询问,我感觉tarjan也许有些大材小用了,因此想哪日补上其他方法,讨论版里有人用dfs过的,也许这个在线的算法也是可以的
下面代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 40010;
struct unit{
    int from,to;
    int next;
    int val;
}save[2*maxn];
struct unit1{
    int from,to;
    int next;
    int num;
}question[2*maxn];
int total,head[maxn],head1[maxn],total1,father[maxn],dis[maxn],LCA[maxn];
bool vis[maxn];
void add(int a,int b,int c){
    save[total].from = a;
    save[total].to = b;
    save[total].next = head[a];
    save[total].val = c;
    head[a] = total++;
}
void add1(int a,int b,int c){
    question[total1].from = a;
    question[total1].to = b;
    question[total1].next = head1[a];
    question[total1].num = c;
    head1[a] = total1++;
}
int Find(int x){
    if(x==father[x]) return father[x];
    return father[x] = Find(father[x]);
}
void tarjan(int u){
    int i,v;
    vis[u] = true;
    father[u] = u;
    for(i=head[u];i!=-1;i=save[i].next){
        v = save[i].to;
        if(!vis[v]){
            dis[v] = dis[u] + save[i].val;
            tarjan(v);
            father[v] = u;
        }
    }
    for(i=head1[u];i!=-1;i=question[i].next){
        v = question[i].to;
        if(vis[v]){
            LCA[question[i].num] = Find(v);
        }
    }
}
bool isRoot[maxn];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        int root;
        scanf("%d",&n);
        int i;
        total=0;
        memset(head,-1,sizeof(head));
        memset(isRoot, false, sizeof(isRoot));
        for(i=1;i<=n-1;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            isRoot[b]=true;
            add(a, b, 1);
            //add(b, a, 1);
        }
        memset(vis,false,sizeof(vis));
        memset(head1,-1,sizeof(head1));
        total1=0;
        int a,b;
        scanf("%d%d",&a,&b);
        add1(a, b, 1);
        add1(b, a, 1);
        for(i=1;isRoot[i];i++);
        root = i;
        dis[root]=0;
        tarjan(root);
        printf("%d\n",LCA[1]);
    }
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值