Parencodings
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 25239 | Accepted: 14884 |
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()()))) P-sequence 4 5 6666 W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2 6 4 5 6 6 6 6 9 4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6 1 1 2 4 5 1 1 3 9
Source
题意:
题目给一行数,这个数字代表括号串每个“)”前面前面有多少个“(”
构造括号串
然后要输出一行数字,每个数字代表每个和“)”配对的“(”离它有多远
zhangjiatao1之前用stack来做括号的匹配,看来还是挺好用的!
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;
const int maxn = 30;
int save[maxn];
int res[maxn];
char line[maxn];
stack<char> killme;
int main(){
int t,n,i,j,k;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
memset(save, -1, sizeof(save));
save[0]=0;
j=0;
for(i=1;i<=n;i++){
scanf("%d",&save[i]);
for(k=1;k<=save[i]-save[i-1];k++){
line[++j] = '(';
}
line[++j] = ')';
}
/*for(i=1;i<=j;i++){
cout<<line[i];
}*/
while(killme.size()){
killme.pop();
}
int now = 0;
k=0;
for(i=1;i<=j;i++){
now = 0;
if(line[i]=='('){
killme.push('(');
}else{
while(killme.top()!='('){
killme.pop();
now++;
}
killme.pop();
//cout<<"i: "<<i<<" "<<now<<endl;
res[++k] = now+1;
for(int index=1;index<=now;index++){
killme.push('*');
}
killme.push('*');
}
}
for(i=1;i<=k;i++){
cout<<res[i]<<" ";
}
cout<<endl;
}
return 0;
}
/*
(((()()())))
(((***)
*/