hdu5818 Joint Stacks 数据结构

Joint Stacks

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1398    Accepted Submission(s): 663


Problem Description
A stack is a data structure in which all insertions and deletions of entries are made at one end, called the "top" of the stack. The last entry which is inserted is the first one that will be removed. In another word, the operations perform in a Last-In-First-Out (LIFO) manner.
A mergeable stack is a stack with "merge" operation. There are three kinds of operation as follows:

- push A x: insert x into stack A
- pop A: remove the top element of stack A
- merge A B: merge stack A and B

After an operation "merge A B", stack A will obtain all elements that A and B contained before, and B will become empty. The elements in the new stack are rearranged according to the time when they were pushed, just like repeating their "push" operations in one stack. See the sample input/output for further explanation.
Given two mergeable stacks A and B, implement operations mentioned above.
 

Input
There are multiple test cases. For each case, the first line contains an integer  N(0<N105) , indicating the number of operations. The next N lines, each contain an instruction "push", "pop" or "merge". The elements of stacks are 32-bit integers. Both A and B are empty initially, and it is guaranteed that "pop" operation would not be performed to an empty stack. N = 0 indicates the end of input.
 

Output
For each case, print a line "Case #t:", where t is the case number (starting from 1). For each "pop" operation, output the element that is popped, in a single line.
 

Sample Input
  
  
4 push A 1 push A 2 pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge A B pop A pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge B A pop B pop B pop B 0
 

Sample Output
  
  
Case #1: 2 1 Case #2: 1 2 3 0 Case #3: 1 2 3 0
 

Author
SYSU
 

Source

很早的题了
之所以能省时间,是因为swap交换的是地址
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <cstdlib>
#include <queue>
#include <stack>
using namespace std;
struct unit{
    int num;
    int time;
};
bool operator<(unit a,unit b){
    return a.time<b.time;
}
priority_queue<unit> a,b;
int main(){
    int n;
    int rnd = 1;
    while(~scanf("%d",&n)&&n){
        while(a.size()){
            a.pop();
        }
        while (b.size()) {
            b.pop();
        }
        
        printf("Case #%d:\n",rnd);
        int i,p=0,digit;
        char sel[10],which;
        unit now;
        for(i=1;i<=n;i++){
            //cin>>sel;
            scanf("%s",sel);
            //cout<<"Sel "<<sel<<endl;
            if(sel[0]=='p'){
                getchar();
                scanf("%c",&which);
                //cout<<"which "<<which<<endl;
                now.time = ++p;
                if(sel[1]=='u'){
                    scanf("%d",&digit);
                    //cout<<"digit "<<digit<<endl;
                    now.num = digit;
                        if(which=='A'){
                            a.push(now);
                        }else{
                            b.push(now);
                        }
                }else{
                        if(which=='A'){
                            now = a.top();
                            printf("%d\n",now.num);
                            a.pop();
                        }else{
                            now = b.top();
                            printf("%d\n",now.num);
                            b.pop();
                        }
                    
                }
            }else{
                char w1,w2;
                getchar();
                scanf("%c %c",&w1,&w2);
                //cout<<"w1 "<<w1<<" w2 "<<w2<<endl;
                bool flag = false;
                if(a.size()>b.size()){
                    swap(a, b);
                    flag = true;
                }
                while(a.size()){
                    now = a.top();
                    a.pop();
                    b.push(now);
                }
                
                if(w1=='A'){
                    swap(a, b);
                }else{
                    
                }
            }
        }
        rnd++;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值