poj3468 A Simple Problem with Integers 线段树懒惰树

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 101414 Accepted: 31648
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


懒惰树,懒惰树,懒惰树

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 1e6+10;
const int INF=0x3f3f3f3f;
struct unit{
    int left;
    int right;
    long long ans;
    long long lazy;
}save[maxn];
int a[maxn];
void build(int l,int r,int index){
    save[index].left = l;
    save[index].right = r;
    save[index].lazy = 0;
    if(l==r){
        save[index].ans = a[l];
        return;
    }
    int middle = (l+r)/2;
    build(l, middle, index<<1);
    build(middle+1, r, index<<1|1);
    save[index].ans = save[index<<1].ans+save[index<<1|1].ans;
}
void push(int index){
    if(save[index].left==save[index].right){
        return ;
    }
    if(save[index].lazy!=0){
        save[index<<1].lazy += save[index].lazy;
        save[index<<1|1].lazy += save[index].lazy;
        save[index<<1].ans += ((save[index<<1].right-save[index<<1].left+1)*save[index].lazy);
        save[index<<1|1].ans += ((save[index<<1|1].right-save[index<<1|1].left+1)*save[index].lazy);
        save[index].lazy = 0;
    }
}
void update(int l,int r,int num,int index){
    save[index].ans += (r-l+1)*num;
    push(index);
    if(save[index].left==l&&save[index].right==r){
        save[index].lazy =num;
        return ;
    }
    int middle = (save[index].left+save[index].right)/2;
    if(r<=middle){
        update(l, r, num, index<<1);
    }else if(l>middle){
        update(l, r, num, index<<1|1);
    }else{
        update(l, middle, num, index<<1);
        update(middle+1, r, num, index<<1|1);
    }
}
long long getSum(int l,int r,int index){
    //cout<<save[index].left<<" "<<save[index].right<<endl;
    if(save[index].left==l&&save[index].right==r){
        return save[index].ans;
    }
    push(index);
    int middle = (save[index].left+save[index].right)/2;
    if(r<=middle){
        return getSum(l,r,index<<1);
    }else if(l>middle){
        return getSum(l,r,index<<1|1);
    }else{
        return getSum(l, middle, index<<1) + getSum(middle+1, r, index<<1|1);
    }
}
char op[10];
int main(){
    int n,q,i,j,x,y,z;
    while(~scanf("%d%d",&n,&q)){
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        build(1, n, 1);
        for(i=1;i<=q;i++){
            scanf("%s",op);
            if(op[0]=='Q'){
                scanf("%d%d",&x,&y);
                printf("%lld\n",getSum(x, y, 1));
            }else{
                scanf("%d%d%d",&x,&y,&z);
                update(x, y, z, 1);
            }
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值