HOJ-1002 A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input2

1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

Tips

根据题目描述可知,计算两个不超过1000位数字的和,显然,利用已有的int long或是long long 都不能满足题目要求,所以这一题我选择的是将长整数存储成字符串的形式。对字符串的每个数字单独进行处理,满十进一。

Code

#include<iostream>
#include<string>
using namespace std;
string r[10]={"0","1","2","3","4","5","6","7","8","9"};
int main(){
    int n,i,j,cnt=1;
    string str1,str2;
    cin>>n;
    for(i=0;i<n;i++){
        cin>>str1>>str2;
        int len1=str1.size();
        int len2=str2.size();
        int flag=0;
        string rs="";
        for(j=1;j<=len1&&j<=len2;j++){
            int digit=(str1[len1-j]-'0')+(str2[len2-j]-'0')+flag;
//            cout<<"digit:"<<digit<<endl;
            flag=digit/10;
            rs=r[digit%10]+rs;
//            cout<<"*"<<rs<<endl;
        }
        while(j<=len1){
            int digit=(str1[len1-j]-'0')+flag;
            flag=digit/10;
            rs=r[digit%10]+rs;
            j++;
        }
        while (j<=len2) {
            int digit=(str2[len2-j]-'0')+flag;
            flag=digit/10;
            rs=r[digit%10]+rs;
            j++;
        }
        if(cnt!=1)
            cout<<endl;
        if(flag)
            rs=r[flag]+rs;
        cout<<"Case "<<cnt<<":"<<endl;
        cout<<str1<<" + "<<str2<<" = "<<rs<<endl;
        cnt++;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值