贪心算法+保留小数点位数

Input
输入数据首先包含一个正整数C,表示有C组测试用例,每组测试用例的第一行是两个整数n和m(0<n<=1000,0<m&lt;=1000),分别表示经费的金额和大米的种类,然后是m行数据,每行包含2个整数p和h(1<=p<=25,1<=h&lt;=100),分别表示单价和对应大米的重量。
 
Output
对于每组测试数据,请输出能够购买大米的最多重量(你可以假设经费买不光所有的大米)。
每个实例的输出占一行,保留2位小数。
 
Sample Input
1
7 2
3 3
4 4
 
Sample Output
2.33
 
这个题主要练习自己对贪心算法的理解,还有对c++保留小数点位数的运算

先贴出我的代码:

#include <iomanip>
#include <iostream>
using namespace std;
struct make {
	float danprice;
	float wei;
};	 
int main()
{
	
	int num;
	make stuch;
	cin>>num;
	int allprice;
	int count;
	float oo=0;
	for(int i=0;i<num;i++)
	{
		cin>>allprice>>count;
	    make *newstu=new make[count];
		for(int n=0;n<count;n++)
		{
			cin>>newstu[n].danprice>>newstu[n].wei;
		}
		for(int a=0;a<count;a++)//冒泡
			for(int b=0;b<count-a-1;b++)
				if(newstu[b].danprice>newstu[b+1].danprice)
				{
					stuch=newstu[b+1];
				    newstu[b+1]=newstu[b];
					newstu[b]=stuch;
				}
		for(int i1=0;i1<n;i1++)//贪心算法
		{
			if(allprice>newstu[i1].danprice*newstu[i1].wei)
			{oo+=newstu[i1].wei;
			allprice-=newstu[i1].danprice*newstu[i1].wei;
			}
			else
			{
				oo+=allprice/newstu[i1].danprice;
				break;
			}
		}
		cout<<fixed<<setprecision(2)<<oo<<endl;
		oo=0;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值