nyoj 308 Substring

Substring

描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X

XCVCX

 
/*
分类:
来源:
思路:
We are giants.
create by Lee_SD on 2017/4/
*/
#include<cctype>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;


int main(){
	string s1,s2,s3;
	int t;
	cin>>t;
	while(t--){
		cin>>s1;
		s2=s1;
		// 反转字符串 
		reverse(s2.begin(),s2.end());
		//字符串长度 
		int len=s1.size();
		
		int maxx=0;
		for(int i=0;i<=len-2;i++){
		
		for(int j=1;j<=len-i;j++)	
		{
			//substr(i,j)返回从i开始长度为j的字符串 
		string::size_type/*类型*/  pos =s2.find(s1.substr(i,j));
		//s2.find(s1)如果s1不是 s2的字串,返回string::npos 
		if(pos!=string::npos){
			if(maxx<j){
				s3=s1.substr(i,j);
				
				maxx=j;
			}
				
			
		}
		}
	
		}
		
		cout<<s3<<endl;
	}
}       


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值