Buy the souvenirs(方案数+01背包)

Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2414    Accepted Submission(s): 923


Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output
  
  
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
 
#include<stdio.h>
#include<cstring> 
#define  N 505

int main ()  
{     
	int t, n, m, val[N], dp[N], p[N];  
    scanf ("%d", &t);  
    
	while (t--)  
    {  
	 
	memset(dp, 0,sizeof(dp));   //初始化
    memset(p,0,sizeof(p));   //初始化
    
	scanf ("%d %d", &n, &m);  
          
	for (int i=1; i<=n; i++)  
    scanf ("%d", &val[i]);  
         
	for(int i=1; i<=n; i++)  
    for(int j=m; j>=val[i]; j--)  
	{ /*若选了物品i后,能买的件数比不选物品i的件数大,即dp[j-val[i]]>dp[j]那么更新dp[j],同时,p[j]的方案数即为p[j-val[i]]例如  AB   AC  ABD  ACD仍为两种,所以p[j]=p[j-val[i]]即可*/		
		if (dp[j] < dp[j-val[i]]+1)  
		{  
		   dp[j] = dp[j-val[i]]+1;  //要注意p[j-val[i]]为0的情况,因此当它为0时,p[j]=1,1即为D
 			if (!p[j-val[i]]) 
			p[j-val[i]]++;  
  			p[j] = p[j-val[i]];  
   		} //若选了物品i后,能买的件数与不选物品i的件数相同,
  			
			  else if (dp[j] == dp[j-val[i]]+1)  
   			  {  
				 if (!p[j-val[i]]) p[j-val[i]]++;  //也要注意p[j-val[i]]=0的情况,当它为0时,p[j]+=1,1即为D
     			p[j] += p[j-val[i]];  //总的方案数即为p[j]+p[j-val[i]]
              }        
	}  
    if (!dp[m]) 
	puts ("Sorry, you can't buy anything.");  
  	else printf ("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n", p[m], dp[m]);  
    }      
	return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值