Game Prediction

Game Prediction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1584    Accepted Submission(s): 891


Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
 

Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.
 

Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
 

Sample Input
  
  
2 5 1 7 2 10 9 6 11 62 63 54 66 65 61 57 56 50 53 48 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4
 

Source
题意:m个人,每个人n张牌。一共有m*n张牌(点数从1,2,3.....n)。现给出你的n张牌(数组a)。求其最少能赢的次数。
思路:一共有m*n个牌,无重复。在m*n中,把除了你出现的n张牌标记出来,转存到数组b。即求b数组能大于a数组的个数。 首先对a,b数组从大到小排序。设置tt作为b数组的下标,初始化为0.for循环对a数组遍历。如果有b[k]>a[i],sum++;结果为n-sum。
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>


using namespace std;
int n,m;
int vis[1002];
int cmp(int a,int b){
	return a>b;
}
int main(){	
	int Case=1;
	while(scanf("%d%d",&m,&n)!=EOF){
	
		if(m==0&&n==0)
		break;
		int a[55];
		int b[55];
		
		memset(vis,0,sizeof(vis));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		
		
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			vis[a[i]]=1;
		}	
		
	//获取b个小于a[i]的最大数	
		int k=0;
		for(int i=m*n;i>=0;i--){
			if(k==n)
			break;
			if(!vis[i])b[k++]=i;	
		}
/*	for(int i=0;i<n;i++)
		printf("%d  ",b[i]);
		printf("\n");*/
		
	
	sort(a,a+n,cmp);//由大到小 
	sort(b,b+n,cmp);
	/*for(int i=0;i<n;i++)
		printf("%d  ",a[i]);
		printf("\n");*/
		
	int tt=0;
	int sum=0;
	for(int i=0;i<n;i++)
	{
		if(a[i]>b[tt])
		continue;
		else {
			tt++;
			sum++;
		}
		
	}
		
	printf("Case %d: %d\n",Case++,n-sum);	
	}	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值