POJ3041:Asteroids

点击打开题目链接


Asteroids

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12568 Accepted: 6829

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source


=====================================题目大意=====================================


Bessie需要驾驶她的宇宙飞船冒着危险穿越一片有着K个小行星的规格为N X N的网状型小行星带。

幸好Bessie的宇宙飞船装备了可以蒸发某一行或某一列上所有小行星的强大武器。

但是使用武器的花费相当昂贵,Bessie希望节约得使用,请帮助她计算蒸发小行星带中所有小行星所需要使用武器的最少次数。


=====================================算法分析=====================================


二分图最大匹配的König定理:最小点覆盖数 = 最大匹配数。


=======================================代码=======================================




#include<stdio.h>
#include<string.h>

int N,K,Linker[505];

bool Edge[505][505],Vis[505];

bool DFS(int U)
{
	for(int v=1;v<=N;++v)
	{
		if(Edge[U][v]&&!Vis[v])
		{
			Vis[v]=true;
			if(Linker[v]==-1||DFS(Linker[v]))
			{
				Linker[v]=U;
				return true;
			}
		}
	}
	return false;
}

int Hungary()
{
	memset(Linker,-1,sizeof(Linker));
	int ans=0;
	for(int u=1;u<=N;++u)
	{
		memset(Vis,0,sizeof(Vis));
		if(DFS(u)) { ++ans; }
	}
	return ans;
}

int main()
{
	while(scanf("%d%d",&N,&K)==2)
	{
		memset(Edge,0,sizeof(Edge));
		for(int i=0;i<K;++i)
		{
			int row,col;
			scanf("%d%d",&row,&col);
			Edge[row][col]=true;
		}
		printf("%d\n",Hungary());
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值