POJ 3041:Asteroids(二分图最大匹配)

http://poj.org/problem?id=3041

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

题意分析:

在一个n*n的网格上有多个小行星, 有一个武器可以一次可以摧毁一整行或一整列的小行星,求最少需要多少次可以摧毁所有小行星。

解题思路:

行和列当点,小行星当边,每个小行星代表行和列之间有一条边,求最大匹配。

每个行和列都只能匹配一次,当所有的含有小行星的行和列都匹配完就证明已经没有小行星可以摧毁了。

#include <stdio.h>
#include <vector>
#include <string.h>
#define N 1020
using namespace std;
int n, m; 
vector<int>e[N];
int book[N], pre[N];
int dfs(int u)
{
	int v, s;
	for(v=0; v<e[u].size(); v++)
	{
		s=e[u][v];
		if(book[s]==0)
		{//printf("!!");
			book[s]=1;
			if(pre[s]==0 || dfs(pre[s]))
			{	
				pre[s]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int u, v, i, sum;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		sum = 0;
		for(i=1; i<=n; i++)
			e[i].clear();
		while(m--)
		{
			scanf("%d%d", &u, &v);
			e[u].push_back(v+n);
			e[v+n].push_back(u);	
		}	
		memset(pre, 0, sizeof(pre));
		for(i=1; i<=n; i++)
		{
			memset(book, 0, sizeof(book));
			if(dfs(i))
				sum++;
		}
		printf("%d\n", sum);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值