HDU1312:Red and Black

点击打开题目链接

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5226    Accepted Submission(s): 3403


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
       
       
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
       
       
45 59 6 13
 

Source
 

Recommend
Eddy
 


=====================================题目大意=====================================


上下左右走地板砖,黑地砖(“.”)可以走,红地砖(“#”)不能走,给出出发位置(“@”)求解最多能走多少块地砖。


=====================================算法分析=====================================


DFS。


=======================================代码=======================================




#include<stdio.h>

#define LEGCORD(X,Y) (0<=X&&X<H&&0<=Y&&Y<W)     //合法坐标

const int Dir[4][2]={{0,-1},{0,1},{-1,0},{1,0}}; 

int W,H,Si,Sj;

char Map[25][25];

int DP(int X,int Y)
{
	Map[X][Y]='#';
	int sum=1;
	for(int n=0;n<4;++n)
	{
		int tmpx=X+Dir[n][0];
		int tmpy=Y+Dir[n][1];
		if(LEGCORD(tmpx,tmpy)&&Map[tmpx][tmpy]=='.')
		{
			sum+=DP(tmpx,tmpy);
		}
	}
	return sum;
}

int main()
{
	while(scanf("%d%d",&W,&H)==2&&W&&H)
	{
		for(int i=0;i<H;++i)
		{
			scanf("%*c%s",Map[i]);
			for(int j=0;j<W;++j)
			{
				if(Map[i][j]=='@') { Si=i; Sj=j; }
			}
		}
        printf("%d\n",DP(Si,Sj));
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值