HDU1312:Red and Black(DFS)

Red and Black

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14 Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Asia 2004, Ehime (Japan), Japan Domestic 


典型的图的深度优先搜索,遍历所有相邻‘.’的情况,注意 @所在的位置也是一个‘.’所以计数器放在DFS递归函数的开始。还有应该注意输入的W,H分别对应的是行还是列
切记要仔细审题

#include<stdio.h>
char map[25][25];
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
int W,H;
int count;
void DFS(int si,int sj)
{
	count++;
	map[si][sj]='#';
	for(int i=0;i<4;i++)
	{
		int x=si+dir[i][0];
		int y=sj+dir[i][1];
		if(x<H&&y<W&&x>=0&&y>=0&&map[x][y]=='.')
		DFS(x,y); 
	}
	return ;
}
int main()
{
	int i,j;
	int si,sj;
	while(~scanf("%d%d%*c",&W,&H))
	{
		if(W == 0 && H == 0)  
            break;  
		for(i=0;i<H;i++)
		{
				for(j=0;j<W;j++)
				{
					scanf("%c",&map[i][j]);
					if(map[i][j]=='@')
						{
							si=i;
							sj=j;
						}
				}
				
			getchar();
		}
		count=0;
		DFS(si,sj);
		printf("%d\n",count);
	}
	return 0;	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值