poj1753

1 篇文章 0 订阅
1 篇文章 0 订阅

首先说一下这道题 很简单 堪称水题 简单的一次暴力bfs 在一秒的时间内足够解出正确答案了

题意为给你一个4*4的棋盘 每一次选中一个棋子(a)时a和它上下左右四个方向上的所有棋子都换到另一种形态(True->false false->true)然后要输出棋盘全白或者全黑的时候为解,这时候输出到达全白或者全黑的步数 如果情况无解输出Impossible,只输入一组数据

下面是原题


Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4



棋只有黑白两种情况 所以可以转换为true和false两种情况

因为每一个棋只有两种情况 所以为了防止超内存可以用一个整数来存储状态

dec(65535) ->bin(1111 1111 1111 1111)所以判断当状态等于0或者65535时即为全黑或全白的情况

然后每次广搜的时候把16种情况加入队列中 并把到达的步数加1

--但是在做的时候忘了把访问过的情况设为true 所以调了好半天…粗心害死程序狗



#include <iostream>
#include <queue>
#include <string.h>

using namespace std;

int main()
{
    int now=0,setp[65536],s=0;
    bool flag = false,vis[65536];
    char ch;
    queue<int>q;
    memset(vis,false,sizeof(vis));
    //初始化结束 开始输入
    for(int i=0; i<4; i++)
    {
        for(int j=0; j<4; j++)
        {
            cin>>ch;
            int temp;
            if(ch == 'b')
            {
                temp = 1;
            }
            else temp = 0;
            now *= 2;
            now += temp;//以此加上本次状态
        }
    }
    q.push(now);//now 为10进制表示的状态 将其转换为2进制则为棋子状态
    vis[now] = true;
    setp[now] = 1;
    while(!q.empty())
    {
        now = q.front();//将队头出队
        //cout<<s++<<"now:"<<now<<endl;
        q.pop();
        if(now == 0|| now ==65535) //判断结束情况
        {
            flag = true;
            break;
        }
        int temp;
        for(int i=0; i<4; i++)
        {
            for(int j=0; j<4; j++)
            {
                temp = now;
                temp ^= 1<<(i+4*j);
                if(i == 0)
                {
                    temp ^= 1<<(i+j*4+1);
                }
                else if(i == 3)
                {
                    temp ^= 1<<(i+j*4-1);
                }
                else
                {
                    temp ^= 1<<(i+j*4+1);
                    temp ^= 1<<(i+j*4-1);
                }//如果i为0 则棋子左边没有棋子 为3则右边没有棋子 
                
                if(j == 0)
                {
                    temp ^= 1<<(i+j*4+4);
                }
                else if(j == 3)
                {
                    temp ^= 1<<(i+j*4-4);
                }
                else
                {
                    temp ^= 1<<(i+j*4+4);
                    temp ^= 1<<(i+j*4-4);
                }//j 同i
                if(vis[temp] == false)
                {
                    setp[temp] = setp[now] + 1;
                    q.push(temp);
                    vis[temp] = true;
                }//如果没有访问则入队
                if(temp == 0|| temp ==65535)
                {
                    flag = true;
                    setp[now] += 1;
                    break;
                }//如果等于最终状态则直接结束并使其输出结果
            }
        }
    }
    if(flag) cout<<setp[now]-1<<endl;
    else cout<<"Impossible"<<endl;
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值