Android Studio(2.2.2) Jdk1.8新特性之lambda表达式使用时报错记录(Android6.0以上运行时权限)

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/l81372500/article/details/80094533

背景:

        android 6.0以上调用摄像头、读写SD卡、通信录、信息等时,仅在AndroidManifest.xml中添加权限是不够的(有些设备是可以的),这就需要我们在代码中申请权限,于是我找了个开源库,看了博客https://blog.csdn.net/yanzhenjie1003/article/details/52503533/开始尝试,里面用到了lambda表达式,报了个错:lambda expressions are not supported at this language level

进入正题

于是我找到了另一篇博客:https://www.jianshu.com/p/f2b58ff0b152

根据博客所说,当前项目的gradle文件里面添加三段代码,但是又报了个错,


我看了https://stackoverflow.com/questions/37020413/android-dex-cannot-parse-version-52-byte-code#,里面说的方法倒是不少,

看着不错,我以为可以解决,一个一个的看,虽然是英文,但是我认真看,还是看了个差不多,然并卵,我的心的崩溃的,没有解决问题,后来在https://blog.csdn.net/fredro/article/details/78671780看到说要添加


我就添加了,同步后出现

还是不行啊 ,我就baidu这个错误,看到了

https://blog.csdn.net/lf0814/article/details/68490588,最后提到了“

删除build.gradle(app)中的“apply plugin: 'me.tatarka.retrolambda'”",我试了一下,问题解决了,记录下来

另外我的gradle是2.2.2,有些人说要升级android studio ,但是我没有升,一样可以了

这个解决办法仅作参考

展开阅读全文

没有更多推荐了,返回首页