02-线性结构4 Pop Sequence (25分)

19 篇文章 0 订阅
这道编程题目要求判断给定的最大容量为M的栈中,按1到N顺序推入N个数字后,是否能通过随机弹出操作得到一系列指定的序列。输入包含一个测试案例,包括M、N和K(要检查的弹出序列数),接下来K行是每种可能的弹出序列。输出需对每个序列标明是否可能。样例输入输出展示了不同情况下的判断结果。
摘要由CSDN通过智能技术生成

02-线性结构4 Pop Sequence (25分)
Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, …, NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:

YES
NO
NO
YES
NO

#include <iostream>
#include <vector>
#include <stack>
#include <set>

using namespace std;

int main(){
    int stackSize;
    int nums;
    int n;
    int tempNum;

    cin>>stackSize>>nums>>n;

    stack<int> s;
    set<int> numCan;
    bool flag = true;

    int arr[1010];


    for(int i = 0; i < n; i++){

        for(int k = 0; k < nums; k++){
            numCan.insert(k+1);
        }

        for(int q = 0; q <nums;q++){
            cin>>arr[q];
        }

        for(int j = 0; j < nums && flag;j++){
            tempNum = arr[j];
            for(int p = 1;p <= tempNum && flag;p++) {
                if (numCan.find(p) != numCan.end()) {
                    if (s.size() < stackSize) {
                        s.push(p);
                        numCan.erase(p);
                    } else {
                        flag = false;
                        cout << "NO" << endl;
                    }
                }
            }

            if(flag){
                int temp = s.top();
                s.pop();
                if(temp != tempNum && flag){
                    flag = false;
                    cout<<"NO"<<endl;
                }
            }
        }
        if(flag){
            cout<<"YES"<<endl;
        }

        flag = true;
        numCan.clear();
        while(s.size() != 0){
            s.pop();
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值