Problem 5: 判断字符类型

Description
输入一个字符,判断字符的类型,即字母(alpha)、数字(numeric)和其它字符(other)。
Input
一个字符。
Output
字符的类型,alpha、numeric或other。
Sample Input
A
Sample Output
alpha
#include<stdio.h>
int main()
{
char ch;
scanf("%c",&ch);
if(ch>=‘a’&&ch<=‘z’||ch>=‘A’&&ch<=‘Z’)
printf(“alpha”);
else if(ch>=‘0’&&ch<=‘9’)
printf(“numeric”);
else
printf(“other”);
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值