D - Oil Deposits(dfs不需要回溯)

此篇博客介绍了一道算法问题,涉及如何通过HDU1241题目中的网格和字符判断地下石油沉积的数量。任务是找出不同石油沉积区域,考虑口袋间的联通性,包括水平、垂直和对角线连接。博主提供了一个C++代码实现,展示了如何用深度优先搜索来划分并计数独立的石油沉积区。
摘要由CSDN通过智能技术生成

HDU 1241
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘ *’, representing the absence of oil, or `@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

大概意思就是找每块与每块之间的联通部分然后找有多少个地方可以联通在一起,这里是八个方向都可以联通部分

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
using namespace std;
int m,n,c;//m行n列 
char mapp[110][110];
int vis[110][110];
int to[8][2]={1,0,0,1,-1,0,0,-1,1,1,1,-1,-1,1,-1,-1};
void dfs(int x,int y){
	if(mapp[x][y]=='@')
		mapp[x][y]='*';
	for(int i=0;i<8;i++){
		int xx=x+to[i][0];
		int yy=y+to[i][1];
		if(xx>=0&&yy>=0&&xx<m&&yy<n&&mapp[xx][yy]=='@')
			dfs(xx,yy);
	}
}
int main(){
	while(scanf("%d%d%d",&m,&n)&&(n||m)){
		int num=0;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				cin>>mapp[i][j];
			}
		}
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				if(mapp[i][j]=='@'){
					dfs(i,j);
					num++;
				}
			}
		}
		cout<<num<<endl;
	}
	
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值