310:Is It A Tree?(判断几棵树,查找有无环 并查集?)

思路妙啊~~~
描述
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
在这里插入图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
输出
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
大致翻译:
树是一种众所周知的数据结构,它既可以是空的(null,void,什么都不是),也可以是一组由一个或多个满足以下属性的有向边连接的节点。
恰好有一个节点,称为根,没有定向边指向该节点。
除根节点外,每个节点都只有一个指向它的边。
从根到每个节点都有唯一的有向边序列。
例如,考虑以下插图,其中节点用圆圈表示,边缘用带箭头的线表示。其中的前两个是树,但最后一个不是。
在这个问题中,您将获得由有向边连接的节点集合的几个描述。对于这些中的每一个,您都要确定集合是否满足树的定义。
输入
输入将包含一系列描述(测试用例),后跟一对负整数。每个测试用例将由一系列的边沿描述,后跟一对零组成。每个边沿描述将由一对整数组成;第一个整数标识边缘开始的节点,第二个整数标识边缘指向的节点。节点号将始终大于零。
输出
对于每个测试用例,显示行“案例k是一棵树”。或“案例k不是树”行,其中k对应于测试案例编号(它们从1开始顺序编号)。
在这里插入图片描述
还有些不理解日后回来补叭。。。
大神的代码(与原代码有一丢丢区别,主要是给自己下次复习的啦)~~~,稍加一点自己的注释

#include <bits/stdc++.h>
using namespace std;
int tree[1000010];//父节点:tree[子节点]
int find(int x){
	if(x!=tree[x]) x=tree[x];
	return x;
}
void fun(int x,int y){
	int xx,yy;
	xx=find(x);
	yy=find(y);
	if(xx!=yy) tree[yy]=xx;
}
int main(){
	int k=0;
	while(1){
		int flag=0,sum=0,f,z;
		memset(tree,0,sizeof(tree));
		while(~scanf("%d%d",&f,&z)&&(f||z)){
			if(f==-1&&z==-1) return 0;
			if(tree[f]==0) tree[f]=f;
			if(tree[z]==0) tree[z]=z;
			if(find(f)==find(z)) flag=1;//找有无环的情况 
			if(flag!=1) fun(f,z);
		}
		for(int i=1;i<=1000;i++)
			if(tree[i]==i)sum++;//查找有几棵树 
		if(flag||sum>1) printf("Case %d is not a tree.\n",++k);
		else printf("Case %d is a tree.\n",++k);
	}
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值