题目
请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。
所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。
输入格式:
输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。
输出格式:
在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。
随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。
输入样例:
This is a test.
The word “this” is the word with the highest frequency.
Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee. But this_8 is different than this, and this, and this…#
this line should be ignored.
输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)
23
5:this
4:is
#include <bits/stdc++.h>
using namespace std;
struct node{
string s;
int num;
}n;
map<string,int>mp;
vector<node>v;
bool cmp(node a,node b){//按字典序排序
if(a.num !=b.num ) return a.num >b.num ;
else return a.s <b.s ;
}
int main(){
string s="";
char c;
while(~scanf("%c",&c)){
if((c>='A'&&c<='Z')||(c>='a'&&c<='z')||(c>='0'&&c<='9')||(c=='_')){//注意样例中给出的一些字符
if(c>='A'&&c<='Z'){
c=c-'A'+'a';
}
if(s.size()<15) s+=c;//单词长度不超过15
}else{
if(s.size()){
mp[s]++;
s="";//清空
}
if(c=='#') break;
}
}
map<string,int>::iterator it;
for(it=mp.begin();it!=mp.end();it++){//将单词放入vector中
n.s =it->first;
n.num =it->second;
v.push_back(n);
}
sort(v.begin(),v.end(),cmp);//排序,方便后续输出
cout<<v.size()<<endl;
int num=v.size()/10;
for(int i=0;i<num;i++){
cout<<v[i].num<<':'<<v[i].s<<endl;
}
return 0;
}