L1-007. 念数字

题目:

输入一个整数,输出每个数字对应的拼音。当整数为负数时,先输出“fu”字。十个数字对应的拼音如下:

0: ling
1: yi
2: er
3: san
4: si
5: wu
6: liu
7: qi
8: ba
9: jiu

输入格式:

输入在一行中给出一个整数,如: 1234 。

提示:整数包括负数、零和正数。

输出格式:

在一行中输出这个整数对应的拼音,每个数字的拼音之间用空格分开,行末没有最后的空格。如 yi er san si

输入样例:
-600
输出样例:
fu liu ling ling

思路:

 用String输入,char转换,最后if输出即可。

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String s = sc.next();
		char[] a = new char[s.length()];
		for (int i = 0; i < s.length(); i++) {
			a[i] = s.charAt(i);
			if (a[i] == '0') {
				System.out.print("ling");
			} else if (a[i] == '1') {
				System.out.print("yi");
			} else if (a[i] == '2') {
				System.out.print("er");
			} else if (a[i] == '3') {
				System.out.print("san");
			} else if (a[i] == '4') {
				System.out.print("si");
			} else if (a[i] == '5') {
				System.out.print("wu");
			} else if (a[i] == '6') {
				System.out.print("liu");
			} else if (a[i] == '7') {
				System.out.print("qi");
			} else if (a[i] == '8') {
				System.out.print("ba");
			} else if (a[i] == '9') {
				System.out.print("jiu");
			} else if (a[i] == '-') {
				System.out.print("fu");
			}
			if (i != s.length() - 1) {
				System.out.print(" ");
			}
		}

	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值