L1-023. 输出GPLT

题目:

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String s = sc.nextLine();
		int countg = 0,countp = 0,countl = 0,countt = 0;
		for(int i=0;i<s.length();i++){
			if(s.charAt(i)=='g'||s.charAt(i)=='G'){
				countg++;
			}else if(s.charAt(i)=='p'||s.charAt(i)=='P'){
				countp++;
			}else if(s.charAt(i)=='l'||s.charAt(i)=='L'){
				countl++;
			}else if(s.charAt(i)=='t'||s.charAt(i)=='T'){
				countt++;
			}
		}
		while(countg != 0||countp != 0||countl != 0||countt != 0){
			if(countg != 0){
				System.out.print("G");
				countg--;
			}
			if(countp != 0){
				System.out.print("P");
				countp--;
			}
			if(countl != 0){
				System.out.print("L");
				countl--;
			}
			if(countt != 0){
				System.out.print("T");
				countt--;
			}
		}
		
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值