【hackerrank】-Day 7: Arrays

24 篇文章 0 订阅
24 篇文章 0 订阅

30-arrays
Objective
Today, we’re learning about the Array data structure. Check out the Tutorial tab for learning materials and an instructional video!

Task
Given an array, , of integers, print ‘s elements in reverse order as a single line of space-separated numbers.

Input Format

The first line contains an integer, (the size of our array).
The second line contains space-separated integers describing array ‘s elements.

Constraints

, where is the integer in the array.
Output Format

Print the elements of array in reverse order as a single line of space-separated numbers.

Sample Input

4
1 4 3 2
Sample Output

2 3 4 1


Current Buffer (saved locally, editable)

#!/bin/python3

import math
import os
import random
import re
import sys



if __name__ == '__main__':
    n = int(input())
    arr = list(map(int, input().rstrip().split()))
    ss = ''
    for i in range(0,n):
        if i == n-1:
            ss = ss + str(arr[n-i-1])
        else:
            ss = ss + str(arr[n-i-1]) + ' '
    print(ss)

Congratulations!

You have passed the sample test cases. Click the submit button to run your code against all the test cases.

Testcase 0
Input (stdin)
4
1 4 3 2
Your Output (stdout)
2 3 4 1
Expected Output
2 3 4 1
Authorsaikiran9194
DifficultyEasy
Max Score30
Submitted By169305
NEED HELP?
View tutorial
View discussions
View editorial
View top submissions
RATE THIS CHALLENGE

MORE DETAILS
Download problem statement
Download sample test cases
Suggest Edits

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值