poj1579

http://poj.org/problem?id=1579

Function Run Fun
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 12822Accepted: 6673

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source

题意很明确:利用他给的方法递归求解。不过This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 这句是关键数据大的话就会TLE,半天不出结果。。要把计算过的结果保存下来。。
#include <stdio.h>
#include <memory.h>
int v[21][21][21];
int w(int a,int b,int c)
{
        if(a<=0||b<=0||c<=0)return 1;
        if(a>20||b>20||c>20)return w(20,20,20);
        if(v[a][b][c]>1)return v[a][b][c];//关键语句:避免重复计算,虽然去掉后结果一样,但是会经历大量计算,导致超时,>1表示已经计算过了,if(a<=0||b<=0||c<=0)return 1;看到吗?
      if(a<b&&b<c)
        {
                v[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
        }
        else 
        {
                v[a][b][c]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);
        }
        return v[a][b][c];
}
int main()
{
        int a,b,c;
        while(scanf("%d%d%d",&a,&b,&c)!=EOF)
        {
                memset(v,-1,sizeof(v));
                if(a==-1&&b==-1&&c==-1)
                        break;
                else
                {
                        printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
                }
        }
        return 0;
}
2012.8.28
#include<stdio.h>
#include<string.h>
int a,b,c;
#define maxn 22
int g[maxn][maxn][maxn];
int w(int a,int b,int c)
{
 if(a<=0||b<=0||c<=0)
  return 1;
 if(a>20||b>20||c>20)
  return w(20,20,20);
 if(g[a][b][c]!=0)//已经计算过的直接返回结果。妙
  return g[a][b][c];
 if(a<b&&b<c)
  return g[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
 else
  return g[a][b][c]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);
}
int main()
{
 while(scanf("%d%d%d",&a,&b,&c)!=EOF)
 {
  if(a==-1&&b==-1&&c==-1)
   break;
  memset(g,0,sizeof(g));
  printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
 }
 return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值