poj2140(1Y)

http://poj.org/problem?id=2140

Herd Sums
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13436Accepted: 8016

Description

The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.

Input

* Line 1: A single integer: N

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.

Sample Input

15

Sample Output

4

Source

题意:很清楚求一个n数可以分成多少个<=n的连续的数相加得到。。如10可以分成10和1+2+3+4共2种可能
15可以分成 15, 7+8, 4+5+6, and 1+2+3+4+5. 一开始我担心会不会超时但是居然
164K250MSC++311B
时间复杂度还不大会求。。
代码如下:
  • Source Code
    #include<stdio.h>
    int main()
    {
            int n;
            while(scanf("%d",&n)!=EOF)
            {
                    int i,j;
                    int count=0;
                    int sum;
                    for(i=1;i<=n;i++)
                    {
                            sum=0;
                            for(j=i;j<=n;j++)
                            {
                                    sum+=j;
                                    if(sum==n)
                                            count++;
                                    else if(sum>n)
                                            break;
                            }
                    }
                    printf("%d\n",count);
            }
            return 0;
    }
    
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值