uva409(字符串)

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=350

409 - Excuses, Excuses!

Time limit: 3.000 seconds

Excuses, Excuses!

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • LinesK+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( tex2html_wrap_inline42 ) and will occupy columns 1 throughL in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!
题意:给你一系列的关键单词,然后给你几个借口(单词),要你找出含有关键单词最多借口,如果有多个,可以按任意顺序输出。
说白了就是先给你m个单词,然后输入n句句子,求句子中有与m个单词一样的单词的个数的最大字符串(可能有多个字符串的拥有的值是一样的,都输出就好了)
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char str[25][80],ss[80];  //str用于存储句子;ss用于存储句子中的单词,是时刻变化的
char word[25][25];  //用于存储关键词
int find(int m)//m表示有多少个单词
{
   int i;
   for(i = 0; i < m; i++)
  if(!strcmp(word[i],ss))  return 1;
   return 0;
}
int main()
  
 //freopen("text.txt","r",stdin);
    int m,n,i,j,cases=0;//m表示输入的单词的个数,n表示输入的句子的个数
    int num[25],top,max;
    while(scanf("%d%d",&m,&n)==2)
 {
          printf("Excuse Set #%d\n",++cases);
          for(i=0;i<m;i++)//输入单词,其中word[0][25]存放第一个单词,word[1][25]存放第二个单词.......
                 scanf("%s",word[i]);
          getchar();  //不可丢,吸收后面的换行
          max=0;
          for(i = 0; i < n; i++)//输入句子,每输入一个句子就和前面的单词进行比较
          {
             gets(str[i]);
             num[i] = 0;//num[]表示句子中有多少个前面输入的单词
             int len = strlen(str[i]);//求字符串的长度
             top = 0;
             for(j = 0; j < len; j++)
             {
                  if(isalpha(str[i][j]))//是英文字母就保存在ss[]中,因为前面输入的word[]单词都是字母
                      ss[top++] = tolower(str[i][j]);
                 else
     {
                      if(top)   //如果s[]不空,就是说输入的字符串不是空的
                      {
                          ss[top] = '\0';  //使ss[]长度为top
                          if(find(m))
         num[i]++;
                           top = 0;
       }
                      else  continue;
     }
             }
             if(num[i] > max) max = num[i];//num[0]保存的是str[0][25]与单词的相同个数,num[1]保存的是str[0][25]与单词的相同个数
          }
          for(i=0;i<n;i++)//可能有多个
                 if(num[i]==max) printf("%s\n",str[i]);
          printf("\n");
       }
       return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值