(还有一个点)uva156

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=92

156 - Ananagrams

Time limit: 3.000 seconds

Ananagrams

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon
题意:输入一个字典(用#结束),把所有的单词判断这些单词是否是ananagram。找那个单词只出现一次(这里不分大小写)。然后呢,再按字典序输出(但是这里需要区分大小写)。

思路:每个大写字母变成小写,把单词中的字母按字典序排,再把单词按字典序排序,然后判断。最后输出没有改变的单词。
#include<stdio.h>
include<stdlib.h>
#include<string.h>
int n;
char word[1010][90],str[1010][90];
int cmp_char(const void*_a,const void*_b)//字符比较函数
{
 char*a=(char*)_a;
 char*b=(char*)_b;
 return *a-*b;
}
int cmp_string(const void*_a,const void*_b)//字符串比较函数
{
 char *a=(char*)_a;
 char*b=(char*)_b;
 return strcmp(a,b);
}
int main()
{
 n=0;
 int i,j;
 for(;;)
 {
  scanf("%s",word[n]);
  if(word[n][0]=='#')//遇到结束符就停止循环
   break;
  n++;
 }
 qsort(word,n,sizeof(word[0]),cmp_string);//给所有的单词排序
 for(i=0;i<n;i++)//把单词全部转化成用小写的字符表示的单词
 {
  int len=strlen(word[i]);
  for(j=0;j<len;j++)
  {
   if('A'<=word[i][j]&&'Z'>=word[i][j])
    str[i][j]=word[i][j]+('a'-'A');
   else
    str[i][j]=word[i][j];
  }
  qsort(str[i],len,sizeof(char),cmp_char);//给每个单词排序
 }
 
 for(i=0;i<n;i++)
 {
  int num=0;
  for(j=0;j<n;j++)
  {
   if(strcmp(str[i],str[j])==0)//嘻嘻,这里之所以是在Num==1的时候输出结果是因为,比较的时候是把自己和包括自己的所有的单词进行比较,和所有的单词比较完之后只有num==1的才是最终要找的 a relative ananagram
   {
    num++;
   }
  }
  if(num==1)
   printf("%s\n",word[i]);//输出原始的但是,而不是排序后的(当然这里的单词已经是要按字典的顺序)
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值