(要经常看)uva216

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=152

216 - Getting in Line

Time limit: 3.000 seconds

 

Getting in Line

Computer networking requires that the computers in the network be linked.

This problem considers a ``linear" network in which the computers are chained together so that each is connected to exactly two others except for the two computers on the ends of the chain which are connected to only one other computer. A picture is shown below. Here the computers are the black dots and their locations in the network are identified by planar coordinates (relative to a coordinate system not shown in the picture).

Distances between linked computers in the network are shown in feet.

(要经常看)uva216

For various reasons it is desirable to minimize the length of cable used.

Your problem is to determine how the computers should be connected into such a chain to minimize the total amount of cable needed. In the installation being constructed, the cabling will run beneath the floor, so the amount of cable used to join 2 adjacent computers on the network will be equal to the distance between the computers plus 16 additional feet of cable to connect from the floor to the computers and provide some slack for ease of installation.

The picture below shows the optimal way of connecting the computers shown above, and the total length of cable required for this configuration is (4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01 feet.

(要经常看)uva216

Input

The input file will consist of a series of data sets. Each data set will begin with a line consisting of a single number indicating the number of computers in a network. Each network has at least 2 and at most 8 computers. A value of 0 for the number of computers indicates the end of input.

After the initial line in a data set specifying the number of computers in a network, each additional line in the data set will give the coordinates of a computer in the network. These coordinates will be integers in the range 0 to 150. No two computers are at identical locations and each computer will be listed once.

Output

The output for each network should include a line which tells the number of the network (as determined by its position in the input data), and one line for each length of cable to be cut to connect each adjacent pair of computers in the network. The final line should be a sentence indicating the total amount of cable used.

In listing the lengths of cable to be cut, traverse the network from one end to the other. (It makes no difference at which end you start.) Use a format similar to the one shown in the sample output, with a line of asterisks separating output for different networks and with distances in feet printed to 2 decimal places.

Sample Input

6
5 19
55 28
38 101
28 62
111 84
43 116
5
11 27
84 99
142 81
88 30
95 38
3
132 73
49 86
72 111
0

Sample Output

**********************************************************
Network #1
Cable requirement to connect (5,19) to (55,28) is 66.80 feet.
Cable requirement to connect (55,28) to (28,62) is 59.42 feet.
Cable requirement to connect (28,62) to (38,101) is 56.26 feet.
Cable requirement to connect (38,101) to (43,116) is 31.81 feet.
Cable requirement to connect (43,116) to (111,84) is 91.15 feet.
Number of feet of cable required is 305.45.
**********************************************************
Network #2
Cable requirement to connect (11,27) to (88,30) is 93.06 feet.
Cable requirement to connect (88,30) to (95,38) is 26.63 feet.
Cable requirement to connect (95,38) to (84,99) is 77.98 feet.
Cable requirement to connect (84,99) to (142,81) is 76.73 feet.
Number of feet of cable required is 274.40.
**********************************************************
Network #3
Cable requirement to connect (132,73) to (72,111) is 87.02 feet.
Cable requirement to connect (72,111) to (49,86) is 49.97 feet.
Number of feet of cable required is 136.99.
 
http://blog.csdn.net/wjjayo/article/details/6225021
题意:求n个点之间的n-1条边的最小距离。。。

#include<stdio.h>
#include<string.h>
#include<math.h>
#define maxn 200
int n,arr[maxn],ans[maxn];
double x[maxn],y[maxn],minsum;
bool vis[maxn];
double dis(double x1,double y1,double x2,double y2)//求两点的距离
{
 return pow((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2),0.5);
}
void dfs(int cur,double sum)//深搜
{
 int i;
 if(cur==n)//边界
 {
  if(sum<minsum)
  {
   minsum=sum;//更新最小值
   memcpy(ans,arr,sizeof(arr));//从源arr所指的内存地址的起始位置开始拷贝n个字节到目标ans所指的内存地址的起始位置中
  }
  return ;
 }
 //if(sum>=minsum)return ;
 for(i=0;i<n;i++)
 {
  if(vis[i])continue;//访问过的话返回继续
  vis[i]=true;//标记当前坐标访问过
  arr[cur]=i;//i赋给当前的结点
  if(cur==0)
   dfs(cur+1,0);
  else
  {
   double t=dis(x[arr[cur]],y[arr[cur]],x[arr[cur-1]],y[arr[cur-1]]);//两点的距离
   dfs(cur+1,sum+t+16);//cur+1向下一个坐标搜索,sum+t+16是累加的距离
  }
  vis[i]=false;//恢复原状
 }
}
int main()
{
//#ifdef LOCAL
 //freopen("input.txt","r",stdin);
//#endif
 int cas=1;
 while(scanf("%d",&n)!=EOF)//有几个点
 {
  if(n==0)//结束的标志
   break;
  int i;
  for(i=0;i<n;i++)
   scanf("%lf %lf",&x[i],&y[i]);//输入坐标(x,y);
  for(i=0;i<n;i++)//**********************
   arr[i]=i;
  minsum=2147483646;//*************最小距离
  memset(vis,0,sizeof(vis));//清零
  dfs(0,0);//从(0,0)开始深搜
  printf("**********************************************************\n");//输出格式
  printf("Network #%d\n",cas++);
  for(i=1;i<n;i++)
  {
   double t=dis(x[ans[i]],y[ans[i]],x[ans[i-1]],y[ans[i-1]]);//相当于xi,yi,x(i-1),y(i-1);
    printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n",(int)x[ans[i-1]],(int)y[ans[i-1]],(int)x[ans[i]],(int)y[ans[i]], t+16);
  }
     printf("Number of feet of cable required is %.2f.\n", minsum);
 }
 return 0;
}

 

 

代码2:比较喜欢

#include<stdio.h>
#include<string.h>
#include<math.h>
#define maxn 100
#include<iostream>
using namespace std;
int x[maxn],y[maxn],ans[maxn],tans[maxn],n,vis[maxn];//x[],y[]对应点的坐标。vis[]表示点是否访问过。tans[]表示
double d[maxn][maxn],minx;//d[][]保存点之间的距离,minx保存最小的距离
double dis(int x1,int  y1,int x2,int y2)//求两点间的距离
{
 return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void dfs(int cur)//深搜
{
 int i;
 if(cur==n)//边界
 {
  double sum=0.0;
  for(i=0;i<n-1;i++)
   sum+=d[tans[i]][tans[i+1]];
  if(sum<minx)//更新最小值,把最小值保存在minx
  {
   memcpy(ans,tans,sizeof(tans));//**********************
   minx=sum;
  }
 }
 else
 {
  for(i=0;i<n;i++)
  {
   if(!vis[i])//没访问过
   {
    vis[i]=1;//标记已经访问过
    tans[cur]=i;//更新当前的坐标
    dfs(cur+1);//进行下一次深搜
    vis[i]=0;//恢复原状
   }
  }
 }
}
int main()
{
 int i,j,cas=1;
 while(scanf("%d",&n)!=EOF)//有多少个点
 {
  if(n==0)//结束标志
   break;
  memset(x,0,sizeof(x));//清零
  memset(y,0,sizeof(y));
  memset(d,0,sizeof(d));
  minx=10000000;
  memset(vis,0,sizeof(vis));//清零
  for(i=0;i<n;i++)
  {
   scanf("%d %d",&x[i],&y[i]);//输入点的坐标
  }
  for(i=0;i<n;i++)
  {
   for(j=i+1;j<n;j++)
    d[i][j]=d[j][i]=dis(x[i],y[i],x[j],y[j]);//构建邻接矩阵
  }
  dfs(0);//从0开始计数,共有n个点
  printf("**********************************************************\n");//输出格式
  printf("Network #%d\n",cas++);
  for(i=0;i<n-1;i++)
  {
   printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n",(int)x[ans[i]],(int)y[ans[i]],(int)x[ans[i+1]],(int)y[ans[i+1]], d[ans[i]][ans[i+1]]+16);
  }
  printf("Number of feet of cable required is %.2f.\n", minx+(n-1)*16);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值