poj2586

http://poj.org/problem?id=2586

Y2K Accounting Bug
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6792Accepted: 3337

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

题意:一个公司1年里面每五个月给出盈利和赤字,共给出8次。并且这五个月最终是亏本的。要你求一年12个月下来是否可以盈利。
说明:这里每五个月是指(12345)(23456)(34567)(45678)(56789)(678910)(7891011)(89101112)。这五个月都是亏本的。要使最终盈利的话就要使使用的赤字最少,这里就涉及贪心的思想。
尽可能的让赤字被尽量多的月份共同使用。。注意一下最后code的一组数据。。
#include<stdio.h>
int main()
{
  int s,d,re;
  while(scanf("%d %d",&s,&d)!=EOF)
  {
    if(4*s-d<0)
      re=10*s-2*d;
    else if(3*s-2*d<0)
      re=8*s-4*d;
    else if(2*s-3*d<0)
      re=6*s-6*d;
    else if(s-4*d<0)
      re=3*s-9*d;
    else re=-1;
    if(re>=0)
      printf("%d\n",re);
    else printf("Deficit\n");
  }
  return 0;
}
//代码2
#include<stdio.h>
int main()
{
  int s,d;
  while(scanf("%d %d",&s,&d)!=EOF)
  {
    int sum=0;
    if(4*s-d<0)
      sum=10*s-2*d;
    else if(3*s-2*d<0)
      sum=8*s-4*d;
    else if(2*s-3*d<0)
      sum=6*s-6*d;
    else if(s-4*d<0)
      sum=3*s-9*d;
    else sum=-1;//不可少
    if(sum<0)
      printf("Deficit\n");
    else printf("%d\n",sum);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值