1poj3624(01背包)

http://poj.org/problem?id=3624

Charm Bracelet
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13207Accepted: 6022

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

题意:就是最简单的0—1背包,没有任何变形。没什么好说的,不会的参照背包九讲。

1Y真高兴。不过效率挺低的

400K250MSC++537B

#include<iostream>
#include<cstring>
using namespace std;
int f[26000],w[13000],c[13000];
int n,m;
int max(int a,int b)
{
 return a>b?a:b;
}
void ZeroOnePack(int cost,int weight)
{
 for(int v=m;v>=cost;v--)
  f[v]=max(f[v],f[v-cost]+weight);
}
int main()
{
 while(cin>>n>>m)
 {
  int i;
  memset(c,0,sizeof(c));
  memset(w,0,sizeof(w));
  for(i=1;i<=n;i++)
   scanf("%d %d",&c[i],&w[i]);
  memset(f,0,sizeof(f));
  for(i=1;i<=n;i++)
  {
   ZeroOnePack(c[i],w[i]);
  }
  printf("%d\n",f[m]);
 }
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值