1poj3176(dp)记忆化搜索

http://poj.org/problem?id=3176

Cow Bowling
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10719Accepted: 7017

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7


3 8

8 1 0

2 7 4 4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

*
3 8
*
8 1 0
*
2 7 4 4
*
4 5 2 6 5
The highest score is achievable by traversing the cows as shown above.

Source

题意:参照白书158..

输入一个n层的三角形,第i层有i个数,求从第1层到第n层的所有路线中,权值之和最大的路线。

规定:第i层的某个数只能连线走到第i+1层中与它位置相邻的两个数中的一个。

  #include<iostream>
#include<cstring>
using namespace std;
int dp[400][400],a[400][400];
int n;
int d(int i,int j)
{
  if(dp[i][j]>=0)return dp[i][j];
  return dp[i][j]=a[i][j]+(i==n?0:d(i+1,j)>d(i+1,j+1)?d(i+1,j):d(i+1,j+1));
}
int main()
{
  while(cin>>n)
  {
    int i,j;
    int sum=0;
    memset(dp,-1,sizeof(dp));
    memset(a,0,sizeof(a));
    for(i=0;i<n;i++)
    {
      for(j=0;j<=i;j++)
      {
        scanf("%d",&a[i][j]);
      }
    }
    printf("%d\n",d(0,0));
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值