1poj1159(dp)

http://poj.org/problem?id=1159

Palindrome
Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 43110Accepted: 14686

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

题意:给你一段字符串,让你求出在中间最少加入几个字符可以让他变成一段回文子串。

解题思路:假设S是一段字符串,S'是S的逆串,则只需求出S与S'的最长公共子序列即可的长度即可,最后用字符串的长度减去最长公共子序列的长度即是这道题目所求的加入的字母的长度。转化为LCS问题即可

mle了好几次最后用short居然过来,不过memory大的吓人啊

49116K

1000MS

168K719MS

后来看到用滚动数组可以解决mle的问题,顺便了解了下,以前只听说过。。

 

#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 5001
char s1[MAXN],s2[MAXN];
int dp[5001][MAXN];//用int的话mle
int maxn(int a,int b)
{
 return a>b?a:b;
}
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF)
 {
  getchar();
  int i,j;
  for(i=1;i<=n;i++)
  {
   scanf("%c",&s1[i]);
   s2[n-i+1]=s1[i];
  }
  memset(dp,0,sizeof(dp));
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=n;j++)
   {
    if(s1[i]==s2[j])
     dp[i][j]=dp[i-1][j-1]+1;
    else
     dp[i][j]=maxn(dp[i-1][j],dp[i][j-1]);
   }
  }
  printf("%d\n",n-dp[n][n]);
 }
 return 0;
}

 

 

 

#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 5001
char s1[MAXN],s2[MAXN];
int dp[2][MAXN];//用int的话mle
int maxn(int a,int b)
{
 return a>b?a:b;
}
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF)
 {
  getchar();
  int i,j;
  for(i=1;i<=n;i++)
  {
   scanf("%c",&s1[i]);
   s2[n-i+1]=s1[i];
  }
  memset(dp,0,sizeof(dp));
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=n;j++)
   {
    if(s1[i]==s2[j])
     dp[i%2][j]=dp[(i-1)%2][j-1]+1;
    else
     dp[i%2][j]=maxn(dp[(i-1)%2][j],dp[i%2][j-1]);
   }
  }
  printf("%d\n",n-dp[n%2][n]);
 }
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值