0.9poj2376(贪心)

http://poj.org/problem?id=2376

Cleaning Shifts
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7316Accepted: 1981

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Source

题意:在给定的连续区间(总是从1开始)里,求最少安排多少头牛,可以使得连续区间任意时刻至少有一头牛工作。典型的贪心。。
#include <iostream>
#include <algorithm>
#include <cstdio>
 
using namespace std;
 
typedef struct
{
  int start;
  int end;
}cow;
 
// 按start升序,start相同则按end降序
bool cmp(const cow &a, const cow &b)
{
  if (a.start == b.start)
  {
    return a.end > b.end;
  }
  return a.start < b.start;
}
 
int main()
{
  int n, t;
  cow array[25010];
  scanf("%d%d", &n, &t);
  for (int i = 0; i < n; i++)
  {
    scanf("%d%d", &array[i].start, &array[i].end);
  }
  sort(array, array+n, cmp);
  // 第一头牛如果不从1开始则肯定无法覆盖全部
  if (array[0].start == 1)
  {
    // 只有一头牛而且它能覆盖全部
    if (array[0].end == t)
      cout << "1" << endl;
    else
    {
      int j = 0;
      int ans = 1;
      int start, end;
      bool find = false;
      // 找2个标记寻找符合start条件里end最大的牛
      start = end = array[0].end;
      // find标记是否可以完全覆盖
      while (!find)
      {
        // 每次在end以后的位置找
        for (int i = j + 1; i < n; i++)
        {
          // start要在前一个范围内,end尽可能要大,下一个的strat和end总是和上一个的end比较..hi
          if (array[i].start-1 <= start && array[i].end > end)
          {
            end = array[i].end;
            j = i;//不加这个tle,为了即使更新下一次的起点
          }
        }
        // 没找到符合条件的牛,肯定无法覆盖
        // 找到结尾则返回成功
        if (start == end)
          break;
        else if (end == t)
          find = true;
        // 牛数量++
        ans++;
        // 把start的位置更新
        start = end;
      }
      if (find)
        cout << ans << endl;
      else
        cout << "-1" << endl;
    }
  }
  else
    cout << "-1" << endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值