1poj1111(dfs)

http://poj.org/problem?id=1111

Image Perimeters
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6527Accepted: 3867

Description

Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects.

The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are

XX Grid 1 .XXX Grid 2
XX .XXX
.XXX
...X
..X.
X...

An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected.

XXX
XXX Central X and adjacent X's
XXX

An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object.

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3.
1poj1111(dfs)

One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18.

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear:

Impossible Possible

XXXX XXXX XXXX XXXX
X..X XXXX X... X...
XX.X XXXX XX.X XX.X
XXXX XXXX XXXX XX.X

..... ..... ..... .....
..X.. ..X.. ..X.. ..X..
.X.X. .XXX. .X... .....
..X.. ..X.. ..X.. ..X..
..... ..... ..... .....

Input

The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters.

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks.

Output

For each grid in the input, the output contains a single line with the perimeter of the specified object.

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0

Sample Output

8
18
40
48
8

Source

题意:在矩形里从一个(x,y)点向八个方向,求与(x,y)联通的区域的周长
专业解释 简单说一下题目意思。先输入一个矩阵,再输入一个X的位置,然后输出与这个X在八个方向能够连起来的所有X组成的图形的周长。。。。
  #include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAXN 30
char map[MAXN][MAXN];
int vis[MAXN][MAXN];
int dir[8][2]={{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};
int  r,c,sum,x,y;
void dfs(int a,int b)
{
  int i;
  vis[a][b]=1;//置当前结点以访问过
  for(i=0;i<8;i++)
  {
    x=a+dir[i][0];//下一个节点的坐标
    y=b+dir[i][1];
    if(x>=1&&x<=r&&y>=1&&y<=c)//当结点不越界
    {
      if(map[x][y]=='X'&&vis[x][y]==0)// 节点等于X且未被访问则继续搜索
        dfs(x,y);
      else if(map[x][y]=='.'&&(x==a||y==b))//节点等于.且在map(a,b)上下左右四向之一时周长+1
        sum++;
    }
    else if(x==a||y==b)//越界情况下若节点在map(a,b)上下左右四向之一时周长+1
      sum++;
  }
}
int main()
{
  int i,j;
  while(scanf("%d%d%d%d",&r,&c,&x,&y)!=EOF)
  {
    if(r==0&&c==0&&x==0&&y==0)
      break;
    memset(vis,0,sizeof(vis));
    for(i=1;i<=r;i++)
    {
      getchar();
      for(j=1;j<=c;j++)
        scanf("%c",&map[i][j]);
    }
    sum=0;
    dfs(x,y);
    printf("%d\n",sum);
  }
  return 0;
}
 
 
代码2:已AC

#include<iostream>
#include<cstring>
using namespace std;
char map[30][30];
int path[30][30];
int num;
int r,c;
int dfs(int x,int y)
{
  if(map[x][y]=='.'||path[x][y]==1)
    return 1;
  path[x][y]=1;
  if(map[x+1][y]=='.')
    num++;
  if(map[x-1][y]=='.')
    num++;
  if(map[x][y-1]=='.')
    num++;
  if(map[x][y+1]=='.')
    num++;
  dfs(x+1,y);dfs(x-1,y);dfs(x,y+1);
  dfs(x,y-1);                    dfs(x+1,y-1);
  dfs(x+1,y+1);dfs(x-1,y-1);dfs(x-1,y+1);
  return num;
}
int main()
{
  int x,y;
  while(cin>>r>>c>>x>>y)
  {
    if(r==0&&c==0&&x==0&&y==0)
      break;
    memset(map,'.',sizeof(map));
    memset(path,0,sizeof(path));
    int i,j;
    for(i=1;i<=r;i++)
    {
      for(j=1;j<=c;j++)
        cin>>map[i][j];
    }
    num=0;
    dfs(x,y);
    cout<<num<<endl;
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值