1105 Spiral Matrix (25分)

 

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×nmust be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76
#include <bits/stdc++.h>
#define INF 9999999
using namespace std;
int nn,n,m,x[4]={0,1,0,-1},y[4]={1,0,-1,0},min_a=INF,p[10005],tx=0,ty=-1,t=0,mat[1000][1000];
bool judge(int px,int py){
    return px>=0&&px<m&&py>=0&&py<n&&mat[px][py]==0;
}

int main(){
    scanf("%d",&nn);
    for(int i=0;i<nn;i++)scanf("%d",&p[i]);
    for(int i=1;i<=sqrt(nn);i++)
    if(nn%i==0&&abs(nn/i-i)<min_a){
        m = max(nn/i, i);
        n = min(nn/i, i);
        min_a=m-n;
    }

    sort(p, p+nn);
    for(int i=nn-1;i>=0;i--)
        if(judge(tx+x[t], ty+y[t])){
            tx+=x[t];
            ty+=y[t];
            mat[tx][ty]=p[i];
        }else {
            i++;
            t = (t+1)%4;
        }
    for(int i=0;i<m;i++){
        for(int j=0;j<n;j++)
            if(j==0)printf("%d",mat[i][j]);
            else printf(" %d",mat[i][j]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值