7-3 树的同构 (25 分)
给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。
图1
图2
现给定两棵树,请你判断它们是否是同构的。
输入格式:
输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (≤10),即该树的结点数(此时假设结点从0到N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。
输出格式:
如果两棵树是同构的,输出“Yes”,否则输出“No”。
输入样例1(对应图1):
8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
输出样例1:
Yes
输入样例2(对应图2):
8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
输出样例2:
No
#include<iostream>
#include<vector>
using namespace std;
typedef struct node {
char data;
int Left;
int Right;
}tree;
typedef struct node2 *position;
typedef position Tree;
struct node2 {
tree* t;
int root;
};
Tree createTree(int l) {
if (l <1) return NULL;
tree *T = (tree*)malloc(sizeof(struct node)*l);
Tree myTree=(Tree)malloc(sizeof(struct node2));
int r;
vector<int> root(l,0);
for (int i = 0; i < l; i++) {
tree t;
cin >> t.data;
char left, right;
cin >> left >> right;
if (left == '-') t.Left = -1;
else {
t.Left = left - '0';
root[t.Left] = 1;
}
if (right == '-') t.Right = -1;
else {
t.Right = right - '0';
root[t.Right] = 1;
}
//cout << "该节点的值为:" << t.data <<"左右子分别为:"<<t.Left<<" "<<t.Right<<endl;
T[i] = t;
}
for (int i = 0; i < l; i++)
if (root[i] == 0) {
r = i;
break;
}
myTree->t = T;
myTree->root = r;
//cout << "根节点为:" << r<<endl;
return myTree;
}
bool judge(Tree a, Tree b,int roota ,int rootb) {
if (roota == rootb&&roota == -1)
return true;
if ((roota == -1 || rootb == -1) && roota != rootb)
return false;
tree x = a->t[roota];
tree y = b->t[rootb];
if (x.data != y.data)
return false;
else
return (judge(a, b, x.Left, y.Left) && judge(a, b, x.Right, y.Right)) || (judge(a, b, x.Left, y.Right)&&judge(a, b, x.Right, y.Left));
}
int main() {
Tree a,b;
int l1, l2;
cin >> l1;
a = createTree(l1);
cin >> l2;
b= createTree(l2);
if (a == NULL || b == NULL) {
cout << "Yes";
return 0;
}
if (judge(a, b, a->root, b->root))
cout << "Yes";
else
cout << "No";
return 0;
}