1016 Phone Bills(测试点解释)

1016 Phone Bills (25 分)

最最扯淡的是,这个题不能用string类读入,必须使用char[].

pat测试点:

0  、1测试点:没有消费的用户不能输出

2测试点:on和off日期不在同一天却在同一个小时

3测试点:on和off日期同一天同一个小时

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

 

#include<iostream>
#include<string>
#include<algorithm>
#include<cstring>

using namespace std;

typedef struct my {
	char name[50];
	int month;
	int day;
	int hour;
	int minute;
	char on_off[25];
}phone;
phone list[1005],start,endt;
int cost[24], n,flag=0,length=0,sum=0;
double total=0;
string name;
bool cmp(phone a, phone b) {
	if (strcmp(a.name, b.name)) return strcmp(a.name, b.name)<0;
	else if (a.day != b.day) return a.day<b.day;
	else if (a.hour != b.hour) return a.hour<b.hour;
	else return a.minute<b.minute;
}
int main() {
	for (int i = 0; i < 24; sum+=cost[i++])
		scanf("%d", &cost[i]);
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%s %d:%d:%d:%d %s", list[i].name, &list[i].month, &list[i].day, &list[i].hour, &list[i].minute, list[i].on_off);
	sort(list, list + n, cmp);
	string name,tname;
	for (int i = 0; i < n-1; i++) {
			 if (strcmp(list[i+1].on_off, "off-line") == 0&&strcmp(list[i].on_off,"on-line")==0&&strcmp(list[i].name, list[i+1].name)==0) {
				 start = list[i];endt = list[++i];	
				tname = string(start.name);
				 if (name != tname) {
					 if (flag)printf("Total amount: $%.2lf\n", total / 100);
					 total = 0;
					 name = tname;
					 printf("%s %02d\n", start.name, start.month);
				 }
					flag = 1;
					double once = 0;
					length = 0;
					if (endt.day > start.day) {            //    if处理跨天的情况
						for (int dd = start.day+1; dd < endt.day; dd++, length += 1440)  //中间跨过的完整的天
							once += 60 * sum;                      
						for (int hh = start.hour + 1; hh < 24; hh++, length += 60)        //开始第一天的剩余时间
							once += (60 * cost[hh]); 
						for (int hh = 0; hh < endt.hour; hh++,length += 60)               //结束日的剩余时间
							once += (60 * cost[hh]); 
					}	
					else                                 //   同一天的情况 
						for (int hh = start.hour + 1; hh < endt.hour; hh++, length += 60)  //跨过的完整小时
							once += (60 * cost[hh]);             
					 if(start.hour==endt.hour&&start.day==endt.day){                     //同一天同一小时
						length += (endt.minute - start.minute);
						once+= cost[start.hour] * (endt.minute - start.minute);
					}
					else {
					length += (60 - start.minute) + endt.minute;	
					once += cost[start.hour] * (60 - start.minute)+cost[endt.hour] * endt.minute;
					}
					total += once;
					printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2lf\n",start.day, start.hour, start.minute,
							endt.day, endt.hour, endt.minute,length,once/100);
			}			  
		}
	if(flag)printf("Total amount: $%.2lf\n", total / 100);	
	return 0;
}

 

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 8
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值