1018 Public Bike Management

1018 Public Bike Management (30 分)

 

解题思路:

先找到最短路径,可dij可dfs,然后对是否选择这条路径的决定则是找到最短路径之后回溯,判断send和back决定。

注意:问题只考虑单向调整,按照路径的顺序,不考虑回到PBMC时调整,否则倒数第三第五个测试点不过

不能只利用贪心判断每个点的最优解,局部最优不一定是整体最优

 

 

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

 

代码: 

#include<iostream>
#include<vector>
#include<stdio.h>
#define INF 65536
using namespace std;

typedef struct MyStruct
{
	int dis;        //最短距离
	int last;       //上一个站点
}sta;

int cmax, ns, sp, m, station[600], road[600][600] = { 0 }, 
x, y, v, t = 0,minsend=INF,minback=INF,shortest=INF;
vector<int> path, bestpath;
sta net[600];


void findpath(int i) {            //回溯路径
	if (i == 0) {
		path.push_back(0);
		return;
	}
	findpath(net[i].last);
	path.push_back(i);
}

void dfs(int start, int distance){   //把dijsktral和dfs合并写
	if (start == sp) {   //每一步贪心并不一定最优,深搜进行检验检验,
		int send = 0, back = 0;
		path = vector<int>();
		findpath(sp);
		for (int i = 0; i < path.size(); i++) {
			if (station[path[i]] > 0)back += station[path[i]];
			else if (station[path[i]] < 0)
				if (back + station[path[i]] >= 0) back += station[path[i]];
				else {
					send = send - station[path[i]] - back;
					back = 0;
				}
		}
		if (distance < shortest||(distance == shortest&&send < minsend)||
			(distance == shortest&&send == minsend&&back<minback)) {
			shortest = distance;
			minsend = send;
			minback = back;
			bestpath = path;
		}
		return;
	}
	for (int i = 1; i <= ns; i++)
		if (road[start][i]) {
			if (distance + road[start][i] <= net[i].dis) {    //dijsktral
				net[i].dis = distance + road[start][i];
				net[i].last = start;
				dfs(i, distance + road[start][i]);
			}
		}
}

int main() {
	scanf("%d %d %d %d", &cmax, &ns, &sp, &m);
	for (int i = 1; i <= ns; i++) {
		scanf("%d", &t);
		station[i] = t - cmax / 2;			//将站内自行车数量转换为剩余量存储
		net[i].dis = INF;					//把未知路径赋值为INF
	}
	for (int i = 0; i < m; i++) {		        //邻接矩阵存储路径
		scanf("%d %d %d", &x, &y, &v);
		road[x][y] = v;
		road[y][x] = v;
	}
	dfs(0, 0);
	printf("%d ", minsend);             //需要带出PBMC的数量
	printf("0");
	for (int i = 1; i<bestpath.size(); i++)
		printf("->%d", bestpath[i]);
	printf(" %d", minback);				//需要带回PBMC的数量
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值