HDU--YAPTCHA--威尔逊定理

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1928    Accepted Submission(s): 987


 

Problem Description

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute


where [x] denotes the largest integer not greater than x.

 

 

Input

The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

 

 

Output

For each n given in the input output the value of Sn.

 

 

Sample Input

 

13 1 2 3 4 5 6 7 8 9 10 100 1000 10000

 

 

Sample Output

 

0 1 1 2 2 2 2 3 3 4 28 207 1609

 

 

判断3*i+7是否是素数,若是则为1,不是则为0。

#include<bits/stdc++.h>
# define ll long long
const int N = 3000000+66;
using namespace std;
int prime[N/10],num_prime=0;
int isNotPrime[N]={1,1};//默认1为非素数
void pre()//筛选N内素数
{
    for(ll i=2;i<=N;i++)
    {
        if(!isNotPrime[i])
            prime[num_prime++]=i;
        for(ll j=0;j<num_prime&&i*prime[j]<N;j++)
        {
            isNotPrime[i*prime[j]]=1;
            if(!(i%prime[j]))break;
        }
    }
}
ll s[N];
void init()
{
    for(int i=1;i<N;i++)
    {
        if(3*i+7>=N)break;
        if(!isNotPrime[3*i+7])
        {
            s[i]=s[i-1]+1;
        }else
        {
            s[i]=s[i-1];
        }
    }
}
int main()
{
    //printf("%.6f",1000.0/(1000+20+20+18));
    int n;
    pre();
    init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%lld\n",s[n]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值