HDU5952--Counting Cliques--DFS

Counting Cliques

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5414    Accepted Submission(s): 1929


 

Problem Description

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

 

 

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

 

 

Output

For each test case, output the number of cliques with size S in the graph.

 

 

Sample Input

 

3 4 3 2 1 2 2 3 3 4 5 9 3 1 3 1 4 1 5 2 3 2 4 2 5 3 4 3 5 4 5 6 15 4 1 2 1 3 1 4 1 5 1 6 2 3 2 4 2 5 2 6 3 4 3 5 3 6 4 5 4 6 5 6

 

 

Sample Output

 

3 7 15

 

 

Source

2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

 

问有多少个S元团

思路,建图的时候把无向图变成有向图,从小到大连边。

若当前d元环+x的度<s,剪枝。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int T;
int n,m,s;
vector<int> g[105];
bool graph[105][105];
int ans;
int path[105];
void dfs(int u,int d) { //当前搜索u点,已经找到d个点的完全图
    if(d==s) {
        ans++;
        return;
    }
    //if(g[u].size()+d<s)
       // return;
    for(int i=0;i<g[u].size();i++) {
        int v=g[u][i];
        bool flag=true;
        for(int j=0;j<d;j++) {
            if(!graph[v][path[j]])
                flag=false;
            if(g[v].size()+1+d<s)
                flag=false;
            if(!flag) break;
        }
        if(flag) {
            path[d]=v;
            dfs(v,d+1);
        }
 
    }
}
int main() {
 
    scanf("%d",&T);
    while(T--) {
        scanf("%d %d %d",&n,&m,&s);
        for(int i=1;i<=n;i++)
            g[i].clear();
        memset(path,0,sizeof(path));
        memset(graph,0,sizeof(graph));
        while(m--) {
            int u,v;
            scanf("%d %d",&u,&v);
            graph[u][v]=graph[v][u]=1;
            g[min(u,v)].push_back(max(u,v));
        }
        ans=0;
        for(int i=1;i<=n;i++) {
 
                path[0]=i;
                dfs(i,1);
        }
        printf("%d\n", ans);
    }
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值