HDU1385Period

http://acm.hdu.edu.cn/showproblem.php?pid=1358

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

 

Sample Input

 

3 aaa 12 aabaabaabaab 0

 

 

Sample Output

 

Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4

 

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<stdio.h>
#include<string.h>
#include<algorithm>
//KMP-性质
//本题利用KMP算法中求Next[]数组的性质可以解决;
//即如果一个字符串为循环串时,(例如adcabcabc)
//那么它的next[]数组满足下面性质:
//1、len%(len-p[len])==0;
//2、len/(len-p[len])就是循环的次数;
//这里len是字符串的长度,p[]是next[]数组;
//刚开始,想的有点挫每次都执行一次Getp函数 ,结果果断超时,最后发现其实一次GetP函数后;只需判断该题中
//字符串前缀能否满足上述两个条件即可;还有就是循环次数不可能为一次;这一点需要注意;(所以就需在判断
//满足条件1后在判断是否len/(len-p[len])=1;等于说明此时的前缀不是周期串;否则就是;直接打印输出即可。 
#include<stdio.h>
#include<string.h>
#include<math.h>
int p[1000010];
char str[1000010];
void getp(int len)      //getp函数,求字符串的next[]数组值 
{                       //这里我把next[]该成了p[];其实一样。 
	int i=0,j=-1;
	p[i]=j;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;j++;p[i]=j;
		}
		else
		j=p[j];
	}
}
int main()
{
	int n,i,j,ca=1;
	while(scanf("%d",&n)&&n)
	{
		memset(str,0,sizeof(str));
		scanf("%s",str);
		getp(n);
		j=0;
		printf("Test case #%d\n",ca++);
		for(i=2;i<=n;i++)
		{
			  if(i%(i-p[i])==0&&i/(i-p[i])>1)  //判断是否为周期串且循环次数是否为1次; 
			  {
			     printf("%d %d\n",i,i/(i-p[i]));
			  }
		}
		printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值