HDU5443线段树||RMQ||模拟

http://acm.hdu.edu.cn/showproblem.php?pid=5443

//找区间内最大值

Problem Description

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing 2 integers l and r , please find out the biggest water source between al and ar .

 

 

Input

First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an , and each integer is in {1,...,106} . On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

 

 

Output

For each query, output an integer representing the size of the biggest water source.

 

 

Sample Input

 

3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3

 

 

Sample Output

 

100 2 3 4 4 5 1 999999 999999 1

//线段树

#include <iostream>
#include <cstdio>
#include <string.h>
#include <string>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int N=1000*4;
struct Node{
	int l,r,big;
}node[N];
void Init(int now,int le,int ri){
	if(le==ri){
		scanf("%d",&node[now].big);
		node[now].l=le;
		node[now].r=ri;	
	//	printf("%d %d %d %d\n",now,node[now].l,node[now].r,node[now].big);
		return;
	}
	int mid=(le+ri)>>1;
	int ne=now<<1;
	node[now].l=le;
	node[now].r=ri;
	Init(ne,le,mid);
	Init(ne+1,mid+1,ri);
	node[now].big=max(node[ne].big,node[ne+1].big);
	//printf("%d %d %d %d\n",now,node[now].l,node[now].r,node[now].big);
}
int find(int now,int a,int b){
	int mid=(node[now].l+node[now].r)>>1;
	int ne=now<<1;
	if(a==node[now].l&&b==node[now].r)
	return node[now].big;
	  else if(b<=mid)
	   return find(ne,a,b);
	   else if(a>mid)
	   return find(ne+1,a,b);
	   else 
	   return max(find(ne,a,mid),find(ne+1,mid+1,b));
}
int main(){
	int t,n,i,j,a,b;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		Init(1,1,n);
			scanf("%d",&i);
			while(i--){
				scanf("%d%d",&a,&b);
				printf("%d\n",find(1,a,b));
			}
	}
	return 0;
}

//RMQ

#include<bits/stdc++.h>
using namespace std;
const int MAXN=1000+1000;
int dmax[MAXN][20];
int dmin[MAXN][20];
int d[MAXN];
void initMax(int n,int d[])
{
    for(int i=1; i<=n; i++)dmax[i][0]=d[i];
    for(int j=1; (1<<j)<=n; j++)
        for(int i=1; i+(1<<j)-1<=n; i++)
            dmax[i][j]=max(dmax[i][j-1],dmax[i+(1<<(j-1))][j-1]);
}
int getMax(int L,int R)
{
    int k=0;
    while((1<<(k+1))<=R-L+1)k++;
    return max( dmax[L][k],dmax[R-(1<<k)+1][k] );
}
void initMin(int n,int d[])
{
    for(int i=1; i<=n; i++)dmin[i][0]=d[i];
    for(int j=1; (1<<j)<=n; j++)
        for(int i=1; i+(1<<j)-1<=n; i++)
            dmin[i][j]=min( dmin[i][j-1],dmin[i+(1<<(j-1))][j-1] );
}
int getMin(int L,int R)
{
    int k=0;
    while((1<<(k+1))<=R-L+1)k++;
    return min( dmin[L][k],dmin[R-(1<<k)+1][k] );
}

int main()
{
    int n,q,t;
    cin>>t;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&d[i]);
        initMax(n,d);
        initMin(n,d);
        scanf("%d",&q);
        while(q--)
        {
            int L,R;
            scanf("%d%d",&L,&R);
            printf("%d\n",getMax(L,R));
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值